shajmasha
?>

Напишите программу дан массив, состоящий из целых чисел. нумерация элементов начинается с 0. напишите программу, которая выведет элементы массива, номера которых четны (0, 2, входные данные сначала задано число n — количество элементов в массиве (1n100 далее через пробел записаны n чисел — элементы массива. массив состоит из целых чисел. выходные данные необходимо вывести все элементы массива с чётными номерами.

Информатика

Ответы

kot271104
Var a:array of integer;
n,i:integer;
begin
  read(n);
  setlength(a,n);
  for i:=0 to n-1 do read(a[i]);
  writeln;
  i:=0;
  while i<=n-1 do begin
    write(a[i]:4);
    i:=i+2;
  end;
end.

Тестовое решение:
5
7 1 3 2 5
7   3   5
Okunev1034
Const 
n=5;

Var
 ar:array[1..n] of integer;
 ar2:array[1..n] of integer;
 i,k:integer;

 function prost(a:integer):boolean;
 var i:integer;
 b:boolean;
  begin
  b:=true;
   for i:=2 to a div 2 do
    if a mod i=0 then
     begin;
      b:=false;
      break;
     end;
   if a=1 then b:=false;
  prost:=b;
 end;

  begin;
 randomize;
 k:=0;
  for i:=1 to n do
   begin;
    ar[i]:=random(101);
    write(ar[i]:4);
   end;
  writeln;
  for i:=1 to n do
  if prost(ar[i]) then
   begin;
    inc(k);
    ar2[k]:=ar[i];
    write(ar2[k]:4);
   end;
end.
nurtilekisakov
Чтобы квадрат вписался в круг, его диагональ должна быть равна диаметру круга. Если трактовать "уместиться" как "пролезть", то диагональ должна быть меньше диаметра..
Формулы площадей квадрата  S₁ и круга S₂ известны, что легко позволяет нам найти нужное условие.
\displaystyle S_1=a^2 \to a=\sqrt{S_1}; \ d=a \sqrt{2}= \sqrt{2S_1} \\ S_2=\frac{\pi D^2}{4} \to D=\sqrt{\frac{4S_2}{\pi}}; \\ d\ \textless \ D \to \sqrt{2S_1}\ \textless \ \sqrt{\frac{4S_2}{\pi}}; \ 2S_1\ \textless \ \frac{4S_2}{\pi} \ \to \ \boxed{\pi s_1\ \textless \ 2S_2}
Если нужно, чтобы случай, когда квадрат вписан в круг тоже учитывался, строгое неравенство следует заменить нестрогим.

// PascalABC.NET 3.0, сборка 1160 от 05.02.2016
begin
  var s1:=ReadReal('Площадь квадрата');
  var s2:=ReadReal('Площадь круга');
  if pi*s1<2*s2 then Writeln('Квадрат умещается в круге')
  else Writeln('Квадрат не умещается в круге')
end.

Тестовое решение:
Площадь квадрата 24.6
Площадь круга 28.4
Квадрат не умещается в круге

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Напишите программу дан массив, состоящий из целых чисел. нумерация элементов начинается с 0. напишите программу, которая выведет элементы массива, номера которых четны (0, 2, входные данные сначала задано число n — количество элементов в массиве (1n100 далее через пробел записаны n чисел — элементы массива. массив состоит из целых чисел. выходные данные необходимо вывести все элементы массива с чётными номерами.
Ваше имя (никнейм)*
Email*
Комментарий*