mayskiyandrey90
?>

Дано целое число х и натуральное число n. составьте алгоритм и напишите программу вычисления х^n

Информатика

Ответы

picassovrn
Var x,n,i,s: integer;
begin
read(x,n);
s:=x;
for i:=1 to n-1 do x:=x*s;
writeln(x);
end.
bal4shovser16
Алг
нач
   цел число элементов, позиция, максимум, минимум
   число элементов:=10
   целтаб a[1:число элементов]
   максимум:=-10000
   минимум:=10000
   нц для позиция от 1 до число элементов
       ввод a[позиция]
       если максимум<a[позиция] то максимум:=a[позиция]
       иначе если минимум>a[позиция] то минимум:=a[позиция]
             все
       все
   кц
   вывод "максимум=",максимум,", минимум=",минимум
кон

Тестовое решение:
>> 15:26:57 - Новая программа* - Выполнение начато
5
15
4
8
-2
7
2
9
11
10
максимум=15, минимум=-2
>> 15:27:49 - Новая программа* - Выполнение завершено
romashka17-90
Var
  mini, min, n, i: integer;

begin
  i := 1; {порядковый номер введенного с клавы числа}
  readln(n); {считываем число в клавиатуры}
  min := n; {присваеваем минимуму первое введенное число. Если будет введено одно число то оно и есть минимум}
  mini := i; {присваеваем порядковый номер минимума}
 
  repeat{повторяем}
    i := i + 1; {порядковый номер введенного с клавы числа}
    readln(n); {считываем число в клавиатуры}
    if (n <> 0) and (min > n) then begin {если введенное число меньше минимума, то заменяем минимум}
      min := n; {присваеваем минимуму число}
      mini := i;{присваеваем порядковый номер минимума}
    end;
  until n = 0;{до тех пор пока n=0}
 
  writeln('index = ', mini);
end.

Что еще не понятно?

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Дано целое число х и натуральное число n. составьте алгоритм и напишите программу вычисления х^n
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

alplakhota67
Astrians
modellisimo-a
tolyan791
iptsr4968
Скворцов
Карева Даниил1537
Матвеев
familumid
valeron7hair7
thebest59
Janaz842060
VladimirBorisovich
Kulikovvl9
v-zhigulin1
▲