ЕВ1873
?>

Pascal. дана строка из строчных букв. между соседними словами - запятая, за последним словом - точка. составить программу, печатающую в алфавитном порядке: 1. все гласные буквы, которые входят в каждое слово. 2. все согласные буквы, которые не входят ни в одно слово.

Информатика

Ответы

emilbadalov
// PascalABC.NET 3.1, сборка 1250 от 28.05.2016
function Гласные_в_слове(w:string):sequence of char;
begin
  Result:=w.ToCharArray.Where(c->Pos(c,'аеёиоуыэюя')>0).Distinct
end;

begin
  var s:=ReadlnString('>');
  var w:=s.ToWords(',','.');
  var P:=Гласные_в_слове(w[0]);
  for var i:=1 to Length(w,0)-1 do begin
    var Q:=Гласные_в_слове(w[i]);
    P:=P.InterSect(Q)
    end;
  P:=P.Sorted;
  if P.Count>0 then begin
    Write('Гласные, которые есть в каждом слове: ');
    P.Println(',')
    end
  else
    Writeln('Нет ни одной одинаковой гласной во всех словах');
  var R:='бвгджзйклмнпрстфхцчшщъь'.ToCharArray.ToList;
  foreach var c in s do
    if c in R then R.Remove(c);
  if R.Count>0 then begin
    Write('Согласные, которых нет ни в одном слове: ');
    R.Println(',')
    end
  else
    Writeln('Все согласные присутствуют в тексте')
end.

Тестовое решение
> фонарик,барахолка,биосфера,волокуша,макароны.
Гласные, которые есть в каждом слове: а,о
Согласные, которых нет ни в одном слове: г,д,ж,з,й,п,т,ц,ч,щ,ъ,ь
Ушакова1902

Если еще актуально:

1. Укажите, что такое информация с точки зрения компьютера:

последовательность 0 и 1

2. Укажите, как называют информацию, с которой работает компьютер:

данные

3. В какой науке информация рассматривается как содержание сообщения, передаваемого в форме знаков или сигналов?

теории информации

4. В кибернетике информация – это

содержание сигналов, передаваемых по каналам связи в системах управления

5. Кто из перечисленных учёных является основателем кибернетики?

Норберт Винер

6. Укажите, какая наука занимается изучением передачи наследственной информации от поколения к поколению через молекулы ДНК:

генетика

7. Укажите, в рамках какой науки информация рассматривается как содержание управляющих сигналов от мозга к мышечным тканям:

нейрофизиология

8. Укажите, какой философской теории информации не существует:

кибернетической

9.Согласно атрибутивной концепции, …

информация возникла вместе со Вселенной

10. Укажите, согласно какой философской концепции информация является свойством всего сущего, всех материальных объектов:

атрибутивной

11. Укажите, что из перечисленного не относится к пониманию информации в рамках функциональной концепции:

информационная деятельность присуща только человеку

12. Укажите, согласно какой философской теории информация существует лишь в человеческом сознании и человеческом восприятии:

антропоцентрической

13. Укажите, что из перечисленного не относится к свойствам информации:

подробность

14. Укажите, с каким видом информации не работает компьютер:

тактильным

15. Укажите, что в информатике подразумевают под понятием «язык»:

знаковую систему для представления и передачи информации\

16. Укажите, какой из перечисленных языков не является естественным:

алгоритмический

17. Укажите, что понимают под кодированием информации:

процесс представления информации, удобный для её хранения и/или передачи

18. Укажите, для достижения какой цели не используется кодирование информации:

для поиска информации

19. Укажите, как называют действия по преобразованию информации в её первоначальную форму представления:

декодирование

20. Укажите, как называют быстрый записи устной речи:

стенография

21. Укажите, что из перечисленного не относится к характеристикам кода Морзе:

равномерный код

22. Укажите, как называют кодирование с целью засекречивания информации:

шифрование

23. Шифр Цезаря – это шифрования, при котором:

каждый символ исходного текста заменяется символом, находящимся на некотором постоянном числе позиций левее или правее него в алфавите

24. Укажите, что необходимо знать, для того чтобы восстановить сообщение, закодированное шифром Виженера:

ключевое слово

Надеюсь, что смогла )

vkorz594

массовость. Это свойство предполагает, что алгоритм должен быть пригоден для решения всех задач данного типа;

дискретность. Означает расчлененность определяемого алгоритмом вычислительного процесса на отдельные этапы, возможность выполнения которых исполнителем (компьютером) не вызывает сомнений

результативность. Указывает на наличие таких исходных данных, для которых реализуемый по заданному алгоритму вычислительный процесс должен через конечное число шагов остановиться и выдать искомый результат

Алгоритм – система точных и понятных предписаний (команд, инструкций, директив) о содержании и последовательности выполнения конечного числа действий, необходимых для решения любой задачи данного типа. Как всякий объект, алгоритм имеет название (имя). Также алгоритм имеет начало и конец.

Понятие алгоритма в информатике является фундаментальным, т. е. таким, которое не определяется через другие, более простые понятия.

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Pascal. дана строка из строчных букв. между соседними словами - запятая, за последним словом - точка. составить программу, печатающую в алфавитном порядке: 1. все гласные буквы, которые входят в каждое слово. 2. все согласные буквы, которые не входят ни в одно слово.
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

nestruev
Amelin-Alipova
mokeevahelena
kit036
sespiridonov
dimiff5
Svetlana191
borvalmok432
viktorovna_Imamaevich679
ValerevnaRustam1072
pbttehnology
vallium8354
mashuska
skorpion7228528
printdecor