Джамалутдинова Докучаев
?>

Паскаль 34 .паскаль.необходимо составить программу вычисления стоимости покупки с учетом скидки. скидка в 3% предоставляется в том случае, если сумма покупки больше 500 рублей, в 5% — если сумма больше 1 000 рублей. формат входных данных: вводится целое число xx (0≤x≤2 в31 степени −1) — стоимость покупки до скидки. формат выходных данных: выведите стоимость покупки c учетом скидки в рублях с округлением до целых в меньшую сторону.

Информатика

Ответы

gorodof4292
Var st,sk:integer;
begin
readln(st);
if st>1000 
 then sk:=trunc(st*0.95)
 else if st>500 then sk:=trunc(st*0.97)
                else sk:=st;
writeln(sk);
end.

Пример:
3000
2850
mikhailkirakosyan
Прямые параллельны между собой, если частное коэффициентов у X и Y равны.
Коэффициент - это числовой множитель в алгебраическом выражении.*
Посчитаем их.

7x + 6y + 9 = 0
У этого уравнения коэффициент у X - 7, а у Y - 6
их частное - это \frac{7}{6}

5x + 7y + 14 = 0
Тут коэффициенты X, Y это 5 и 7
их частное - \frac{5}{7}

8x + 6y + 19 = 0
Тут коэффициенты X, Y это 8 и 6
их частное - \frac{8}{6}
сократим дробь на 2, получим \frac{4}{3}

15x + 21y + 22 = 0
Тут коэффициенты X, Y это 15 и 21
их частное - \frac{15}{21}
сократим дробь на 3, получим \frac{5}{7}

10x + 14y + 4 = 0
Тут коэффициенты X, Y это 10 и 14
их частное - \frac{10}{14}
сократим дробь на 2, получим \frac{5}{7}

И того у нас получилось 3 равные дроби, это и есть те уравнения.
5x + 7y + 14 = 0
15x + 21y + 22 = 0
10x + 14y + 4 = 0
Aivazyan
Program pr2;
uses crt;
var
m,n,i,j,k,l:integer;
mas: array[1..99,1..99] of integer;
masb: array [1..99] of integer;
begin
clrscr;
write('vvedite m');
readln(m);
write('vvedite n');
readln(n);
writeln('vvedite massiv MxN')
;for i:=1 to m do
for j:=1 to n do
begin
write('mas[',i,',',j,']= ');
readln(mas[i,j]);
end;
for i:=1 to m do
begin
k:=mas[i,1];
l:=mas[i,1];
for j:=1 to n do
begin
if k < mas[i,j] then k:=mas[i,j];
if l > mas[i,j] then l:=mas[i,j];
end;
masb[i]:=k-l;

end;
for i:=1 to m do
begin
for j:=1 to n do
write(mas[i,j],' ');
writeln('result = ',masb[i]);
end;
readln(i)
end.

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Паскаль 34 .паскаль.необходимо составить программу вычисления стоимости покупки с учетом скидки. скидка в 3% предоставляется в том случае, если сумма покупки больше 500 рублей, в 5% — если сумма больше 1 000 рублей. формат входных данных: вводится целое число xx (0≤x≤2 в31 степени −1) — стоимость покупки до скидки. формат выходных данных: выведите стоимость покупки c учетом скидки в рублях с округлением до целых в меньшую сторону.
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

olesyashazk5055
Seropyan-Elena1944
Vasilii1891
alvs9
Vova220
Vitalik6928
Дементьева-Артем1315
Viktorovna
Анатольевич-Лариса
karkh267
denis302007
cheshirsky-kot
mishapavlov9
travkinadjey31
elenalusia