Николаевич1033
?>

Python файлы капитан флинт зарыл клад на острове сокровищ. он оставил описание, как найти клад. описание состоит из строк вида: "north 5", где слово – одно из "north", "south", "east", "west", – задает направление движения, а число – количество шагов, которое необходимо пройти в этом направлении. напишите программу, которая по описанию пути к кладу определяет точные координаты клада, считая, что начало координат находится в начале пути, ось ox направлена на восток, ось oy – на север. входные данные на вход подается последовательность строк указанного формата. гарантируется, что числа не превосходят 108. выходные данные необходимо вывести координаты клада – два целых числа через пробел. гарантируется, что эти числа не превосходят 108.

Информатика

Ответы

migor72
ответ на 1 задачу
Алгоритм выглядит таким образом:
ввести x, y;
если x>y то
 s:=(x*y)*2;
иначе
 s:=(x+y)/2;
вывод s
конец. (блок-схема прилагается в скриншоте 1)

На паскале выглядит примерно так:
var
 x, y, s:real;
begin
readln(x,y);
if x>y then
s:=(x*y)*2;
else
s:=(x+y)/2;

writeln(s:2:2);
end.

ответ на 2 задачу
Тут идентичный алгоритм: вводим 2 переменные x, y, далее создаем условие и возводим в модуль... (скриншот 2 с блок-схемой)

ответ на 3 задачу
Тут тоже.. в условии указываешь просто a<b<c, если условие верно, то выводишь "Верно", иначе "Не верно".

На паскале выглядит примерно так:

var
 a, b, c:integer; {если число вещественное}
begin
readln(a, b, c); 
if (a<b<c) then
writeln("Верно");
else
writeln("Неверно");
end.

ответ на 4 задачу
На паскале:
var
 a, b, c, max:integer;
begin
max:=0;
readln(a,b,c);
if max<a then
max:=a;
if max<b then
max:=b;
if max<c then
max:=c;

writeln(max);
end.

ответ на 5 вопрос
На паскале:

Var
a,b,c:integer;
begin
readln(a,b,c);
if (a<0) then
a:=a*a;
writeln(a);

if (b<0) then
b:=b*b;
writeln(b);

if (c<0) then
c:=c*c;
writeln(c);
end.

Удачи!


Составить алгоритм ! составить алгоритм и блок- к каждой . кто хорошо разбирается, ! 1. даны действи
Составить алгоритм ! составить алгоритм и блок- к каждой . кто хорошо разбирается, ! 1. даны действи
klimenokvapeshop1408

Объектом изучения информатики, в широком смысле, является когнитивная пирамида Данные-Информация-Знание-Мудрость. Комплекс теоретических и прикладных дисциплин, объединяемых термином "информатика" сегодня сконценрирован на нижних уровнях этой пирамиды: данных (теория вычислений, алгоритмы) и информации (теория коммуникации, кодирование). Знание и мудрость выпадают из научного рассмотрения, равно как и фундаментальные вопросы, пронизывающие всю пирамиду. В настоящее время даже различия уровней этой пирамиды между собой не вполне ясны. Что отличает знание от информации? Что отличает мудрость от знания?

Делом ближнего будущего является создание подлинно научной теории знания, а в более отдаленной перспективе - и теории мудрости. За теоретическими достижениями последуют практические приложения. Компьютеры будут не только быстро оперировать с данными и перерабатывать огромные объемы информации, но также генерировать новые знания и проявлять мудрость в их применении.  

Так же как это случилось на нижних уровнях, компьютеры быстро превзойдут естественные человеческие в высших аспектах когнитивной деятельности. Разумеется, люди не захотят остаться в таких важных областях позади своих созданий и прибегнут в массовом порядке к искусственному усилению собственного интеллекта.  

Уже сегодня можно отметить черты "симбиоза" человек-машина: виртуальная реальность, "интимные" отношения с персональным компьютером, разнообразные медицинские устройства и протезы и т.п. В ближайшем будущем будет усовершенствован нейро-электронный интерфейс и создано программное обеспечение, которое позволит практически телепатическое управление компьютером. В некоторых ситуациях сами люди будут подвергаться прямому компьютерному управлению.

Человеческий геном претерпит постепенную модификацию с целью повышения эффективности взаимодействия с компьютерами, а также облегчения приживления разнообразных имплантов. В результате человек превратится в киборга, состоящего из электронных, оптронных и клеточных органов. Эти органы будут легко заменяемыми. Вообще, элементная база любого органа будет выбираться в соответствии с конкретными потребностями данного индивидуума. Так, например, для исследования космического пространства будут собирать людей с минимумом клеточных компонент, или даже полным отсутствием таковых. Граница между человеком и компьютером, естественным и искусственным, будет стерта.

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Python файлы капитан флинт зарыл клад на острове сокровищ. он оставил описание, как найти клад. описание состоит из строк вида: "north 5", где слово – одно из "north", "south", "east", "west", – задает направление движения, а число – количество шагов, которое необходимо пройти в этом направлении. напишите программу, которая по описанию пути к кладу определяет точные координаты клада, считая, что начало координат находится в начале пути, ось ox направлена на восток, ось oy – на север. входные данные на вход подается последовательность строк указанного формата. гарантируется, что числа не превосходят 108. выходные данные необходимо вывести координаты клада – два целых числа через пробел. гарантируется, что эти числа не превосходят 108.
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

bagrjashv41
mrFuz
many858
vovlyur
VSpivak3122
Melnik Kaveshnikova1746
Japancosmetica
djikia88
aleksey7800
Васильев1028
nane2924329
fucingprinces30
most315
Kamil
rikki07834591