Суханова1532
?>

C++ или паскаль. нужно решение (динамическое программирование) найдите количество невырожденных прямоугольников со сторонами, параллельными осям координат, вершины которых лежат в точках с целыми координатами внутри или на границе прямоугольника, противоположные углы которого находятся в точках (0, 0) и (w, н входные данные входной файл input.txt содержит два натуральных числа w и н, не превосходящих 1000. выходные данные в выходной файл output.txt выведите ответ на .

Информатика

Ответы

stasyan
#include <fstream>
using namespace std;

int main() {
    long long w, h;
    ifstream fin("input.txt");
    ofstream fout("output.txt");
    fin >> w >> h;
    long long s = 0;
    for (long long i = 1; i != w + 1; ++i) {
        for (long long j = 1; j != h + 1; ++j) {
            s += i * j;
        }
     }
     fout << s;
}
Щуплова Александр
Алгоритм
1) a x a = a² ⇒ b;    b x a = a³ ⇒ результат
2) a x a = a² ⇒ b;    b x b = a⁴ ⇒ c;   c x c = a⁸ ⇒ c;   c x b = a¹⁰ ⇒ результат

Программа на языке PascalABC.Net
var
  a,b,c,y:real;
begin
  Write('Введите число: '); Read(a);
  b:=a*a; y:=b*a; Writeln('Третья степень числа равна ',y);
  c:=b*b; c:=c*c; y:=b*c;
  Writeln('Десятая степень числа равна ',y)
end.

Тестовые решения:
Введите число: 2
Третья степень числа равна 8
Десятая степень числа равна 1024

Введите число: -13.594
Третья степень числа равна -2512.128188584
Десятая степень числа равна 215512594781.574
a800000
1) Как представлено число 8310 в двоичной системе счисления?
В этом вопросе нет ни одного числа двоичного кода. В двоичном коде будет: 10000001110110
2) Дано: , . Какое из чисел С, записанных в двоичной системе счисления, удовлетворяет неравенству ? Я думаю, что вопрос звучал так: Дано: a=222 8 , b=94 Какое из чисел С, записанных в двоичной системе счисления, удовлетворяет неравенству?ответ:2)  С = 250(8сч) удоволетворяет неравенству а=247 меньше С=250 и b= 251 больше С=250.
3) Даны 4 целых числа, записанные в двоичной системе...
ответ: все четыре числа меньше чем 396
4) Укажите через запятую в порядке возрастания все основания систем счисления, в которых запись числа 39 оканчивается на 3.
ответ: 4, 6, 9, 12, 18, 36
5) Запись числа 30 в некоторой системе счисления выглядит так: 110N. Найдите основание системы счисления N.
1)30=1*N^{2}+*N^{1}+*N^{0}
N^{2}+N-30=0
(N+6)(N-5)=0 N\geq=5
2)2B_{16}=2*16+11=43=1*N^{1}+1*N^{0}
N^{2}+N-42=0
(N+7)(N-6)=^{0}N \geq 0 N=6
6) Решить уравнение: где????????????????
7) Сколько единиц в двоичной записи числа 42016 + 22018 – 6?
Я не смог решить
8) Значение арифметического выражения: 274 – 95 + 38 – 25 записали в системе счисления с основанием 3. Сколько цифр «2» содержится в этой записи?
Я не смог решить

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

C++ или паскаль. нужно решение (динамическое программирование) найдите количество невырожденных прямоугольников со сторонами, параллельными осям координат, вершины которых лежат в точках с целыми координатами внутри или на границе прямоугольника, противоположные углы которого находятся в точках (0, 0) и (w, н входные данные входной файл input.txt содержит два натуральных числа w и н, не превосходящих 1000. выходные данные в выходной файл output.txt выведите ответ на .
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

reinish23
Berezovskaya
Картузов-Алексей1252
Лилит_Шутова
Дарья16
MaratФам
Kashtanov Anna
Fedorovich309
Kamil
Goldglobe
baeva-larisa8165
avdoyan6621
Ignateva737
sttig
stairov536