yrgenson2011801
?>

Составьте программу, которая формирует массив из десяти случайных чисел от -45 до 45 и меняет местами значение первого и последнего элементов

Информатика

Ответы

Yanusik24
// PascalABC.NET 3.2, сборка 1362 от 14.12.2016
// Внимание! Если программа не работает, обновите версию!

begin
  var a:=ArrRandom(10,-45,45); a.Println;
  Swap(a[0],a[9]); a.Println
end.

Пример
32 -1 21 17 13 11 -7 14 -7 4
4 -1 21 17 13 11 -7 14 -7 32
Горностаева831
Type mas= Array [1..10] of integer;
var i,M:integer;
a:mas;
begin
randomize;
for i:=1 to 10
do begin
A[i]:=random (-45,45);
write(A[i],' ');
end;
writeln();
A[1]:=M
A[i]:=A[10]; 
A[10]:=M;
for i:=1 to 10
do write(A[i],' ');
end.
bagrjashv41
Ответ : равномерное кодирование удобно для декодирования. однако часто применяют и неравномерные коды, т.е. коды с различной длиной кодовых слов. это полезно, когда в исходном тексте разные буквы встречаются с разной частотой. тогда часто встречающиеся символы стоит кодировать более короткими словами, а редкие – более длинными. из примера 1 видно, что (в отличие от равномерных кодов! ) не все неравномерные коды допускают однозначное декодирование.

есть простое условие, при выполнении которого неравномерный код допускает однозначное декодирование.

код называется префиксным, если в нем нет ни одного кодового слова, которое было бы началом (по-научному, - префиксом) другого кодового слова.

код из примера 1 – не префиксный, так как, например, код буквы а (т.е. кодовое слово 1) – префикс кода буквы к (т.е. кодового слова 12, префикс выделен жирным шрифтом).
ehrik-ch

45. ОЗУ, Кэш, рпп

46. Ширина ячейки не вмещает в себя результат

47. Да

48. Драйвер - программа для подключения какого-либо устройства к ОС и работы с ней

49. При абсолютной ссылке добавляют знак $, который позволяет при копировании не изменять строку/столбец

50. Монитор, принтер, колонки, проектор

51. Всплывает меню задач которые можно выполнить над данным файлом/папкой

52. ОС - комплекс программ, предназначенных для управления ресурсами компьютера

53. Все файлы и текст

54-64. устала я)

65. CD-RW

66. Программа — последовательность инструкций, предназначенная для исполнения устройством УВМ.

67.  С равно (=)

68. DOCX, DOCM, DOTX, DOTM

69. К прикладному программному обеспечению

70. Программа предназначенная для просмотра web страниц, поиска информации и т.д.

71. Notepad, TextPad

, MS Word, WordPad, Excel

72.RAW, JPEG, GIF, PNG, TIFF, PSD

73. Форма в Access — это объект базы данных, который можно использовать для создания пользовательского интерфейса для приложения базы данных

74. Normal.dot

75. БД - множество данных организованных  для быстрого и удобного поиска информации

76. Растровые форматы TIFF, JPEG

Векторные форматы DWG, DXF

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Составьте программу, которая формирует массив из десяти случайных чисел от -45 до 45 и меняет местами значение первого и последнего элементов
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

Olesyamilenina8
АминаИван
bagramyansvetlana
Mashkov-Daniil1764
adminaa
membuksdk
m79857860146895
Николаевна_Анна670
deshkina82
Галина-Юлия1292
VladimirovnaBugrova
Ямпольский
svetavancevich
Спивак
Кириллов57