elmira01048775
?>

Дано: а, b - основ. равнобедр. трапеции; с - боковая сторона; найти: s 1) решить 2) составить блок-схему 3) составить программу

Информатика

Ответы

Ерцкин_Овечкина391
Блок-схема - в прилагаемом файле.
var a,b,c,s:real;
begin
writeln('a, b, c:');
readln(a,b,c);
s:=(a+b)/2*sqrt(c*c-sqr(a-b)/4);
writeln('s = ',s:5:3);
end.

Пример:
a, b, c:
5 3 4
s = 15.492
манукян29
Var a,b,c:integer;
begin
writeln('Введите a: ');
readln(a);
writeln('Введите b: ');
readln(b);
writeln('Введите с: ');
readln(c);
writeln('p= ',a+b/2*sqrt(c*c-sqr(a-b)/4))
end.

Дано: а, b - основ. равнобедр. трапеции; с - боковая сторона; найти: s 1) решить 2) составить блок-с
compm
1)32Кбайт=32*1024байт=32768байт
1байт=8бит
32768байт=32768*8 бит=262144бит
262 144 бит/(4096 бит/с)=64с
64с*1024бит/с=65536бит-размер
65536бит=65536/8 бит=8192байт
2)
60 кбайт=60*1024 байт=61440 байт
1 байт=8 бит
61440 байт=61440*8 бит=491520бит
491520/4096=120с
491520/1024=480с
4080-120=360с=6минут
3)
2Кбайт=2*1024байт=2048 байт=16384 бит
16384/256=64 секунд
64*2048бит=131072 бит=16384 байт
4)
8Мбайт=8*1024к байт=8*1024*1024байт=8388608байт
8388608/100=83886,08 байт/с
83886,08 байт/с*25с=2097152 байт=2048Кбайт
5)
Файл размером 8 Кбайт передается через некоторое соединение за 64 секунды.Определите, за сколько секунд можно передать этот же файл через соединение,скорость которого на 1024 бит в секунду больше 
8Кбайт=8192байт=65536 бит
65536бит/64с=1024 бит/с
1024 бит/с+1024 бит/с=2048 бит/с
65536 бит/(2048 бит/с)=32с
Alenachernika9111

1. Во втором письме содержится меньшее количество информации на 5 500 бит

2. 256 секунд

Объяснение:

1.

I = К * i, где

I - информационный объём письма (документа)

К - количество символов в письме (документе)

i - информационный вес символа (количество бит, которым кодируется 1 символ)

N = 2^i, где

N - мощность алфавита (количество символов в алфавите)

i - информационный вес символа (количество бит, которым кодируется 1 символ)

Дано:

K₁ = 25 строк * 50 символов = 1 250 символов

N₁ = 256 символа

K₂ = 2 страницы * 15 строк * 30 символов = 900 символов

N₂ = 32 символа

Найти:

I ₁ - I₂

256 = 2^i ₁

i₁ = 8 бит

32 = 2^i ₂

i₂ = 5 бит

I₁ = 1 250 * 8 = 10 000 бит

I₂ = 900 * 5 = 4 500 бит

I ₁ - I₂ = 10 000 - 4 500 = 5 500 бит

2.

I = К * i, где

I - информационный объём сообщения (документа)

К - количество символов в сообщении (документе)

i - информационный вес символа (количество бит, которым кодируется 1 символ)

К = V * t, где

K - количество символов в сообщении (документе)

V - скорость печати принтера

t - время печати принтера

Дано:

V = 1 024 символа/с

I = 256 Кбайт = 262 144 байт

i = 1 байт (предположительно)

Найти:

t

I = К * i

К = I / i

К = 262 144 / 1 = 262 144 символов

К = V * t

t = К / V

t = 262 144 / 1 024 = 256 секунд

1 Кбайт = 1024 байт

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Дано: а, b - основ. равнобедр. трапеции; с - боковая сторона; найти: s 1) решить 2) составить блок-схему 3) составить программу
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

Georgievich-Zamudinovna2003
ddavydov1116
Головин662
Дмитрий_Евлампиев518
AverinAA6077
prettymarina2015
appbiznessm
mishapavlov9
artemiusst
vikola2008
kmr495270
Dmitrievna405
Чубкова1290
Less2014
АлександровнаВладлен243