Напишите программу.даны три действительных числа. возвести в квадрат те из них, значения которых неотрицательны, и в четвертую степень — отрицательные.
// PascalABC.NET 3.2, сборка 1399 от 08.03.2017 // Внимание! Если программа не работает, обновите версию!
begin ReadSeqReal(3).Select(x->x<0?sqr(x*x):x*x).Println end.
Пример 3.18 -5.722 1.94 10.1124 1071.99167796866 3.7636
Борисовна_Дмитриевич1003
25.04.2023
Var mas:array[1..3] of integer; begin for var i := 1 to 3 do begin read(mas[i]); if mas[i] >= 0 then mas[i] := sqr(mas[i]) else mas[i] := sqr(mas[i]) * sqr(mas[i]); end.
ivanlimeexpo
25.04.2023
Как ч понял сортировка по неубыванию это сортировка по возрастанию. То есть легкие элементы всплывают наверх, а тяжелые перемещаются вниз:
//Pascal const m = 1000 var arr: array[1..m] of integer; n,i, j, k: integer; begin readln(n); write ('Исходный массив: '); for i := 1 to n do begin readln(arr[i]); end; //сортировка методом пузырька for i := 1 to n-1 do for j := 1 to n-i do if arr[j] > arr[j+1] then begin k := arr[j]; arr[j] := arr[j+1]; arr[j+1] := k end;
write ('Отсортированный массив: '); for i := 1 to n do write (arr[i]:4); end.
Алгоритм сортировки на классическом языке программирования С
# define SWAP(A,B) {A=A^B;B=A^B;A=A^B;} void bubblesort(int A[], int n) { int i, j; for(i = n-1 ; i > 0 ; i--) { for(j = 0 ; j < i ; j++) { if( A[j] > A[j+1] ) SWAP(A[j],A[j+1]); } } }
// Внимание! Если программа не работает, обновите версию!
begin
ReadSeqReal(3).Select(x->x<0?sqr(x*x):x*x).Println
end.
Пример
3.18 -5.722 1.94
10.1124 1071.99167796866 3.7636