?>
Дано натуральное число n, последовательность целых чисел a1, .составить программу , которая последовательно прибавляя членв последовательности, выводит результат, когда сумма впервые превышает число n. если сумма всех членов последовательности не превышает число n, выведите об этом сообщение
Ответы
n = 5;
var
arr: array [1..n] of integer;
i, N1, sum: integer;
begin
write('N = ');
readln(N1);
for i := 1 to n do
begin
write('A[', i, '] = ');
readln(arr[i]);
end;
i := 1;
sum := 0;
while (sum <= N1) and (i <= n) do
begin
sum := sum + arr[i];
i := i + 1;
end;
if sum > N1 then
writeln(sum)
else
writeln('Summa not grether then N');
end.