Anna Artem
?>

Номер 1 напечатать сумму элементов кратных одновременно двум или трем числового ряда 3, 6, 9, 2, 12, 2, 24 и 2 составить программу вычисления числового ряда для известного числа ряда n. y=(1-2/5)+(2+4/10)+(3-8/15)+(4+16/20)+

Информатика

Ответы

Наталья

program zadacha2;

  uses crt;

  var i,n,a: integer;

            b,y,c,l: real;

begin

clrscr;

readln(n);

  a: =1;

  b: =2;

  c: =5;

  for i: =1 to n do                                                                                          

                                                                                                  begin  

if a mod 2 = 0 then

l: =a+b/c

else          

l: =a-b/c;

a: =a+1;

b: =b+2;

c: =c+5;

y: =y+l;

                                                                                                    end;

writeln(y: 2: 2);

readkey;

  end.

первую по подробней расспишите

avdeevo
Так как на востоке растут либо вишня, либо слива, то там не могут расти груша и яблоня, ставим минусы в таблицу. так как по обе стороны от груши должны расти яблоня и слива, то для груши остаётся место только на западе (так как север и юг будут свободны), ставит плюс в в таблице на пересечении груша/запад, а по вертикали и горизонтали все свободное заполняем минусами. "сторона света, в которой растет груша соседняя со стороной света, в которой растет яблоня и соседняя со стороной света, в которой растет слива." нам известно, что слива может расти на востоке, но восток - сторона, не соседняя с западом, значит, на востоке слива расти не может, тогда на востоке растет вишня. ставим плюс в таблице на пересечении восток/вишня, по горизонтали и вертикали от этого плюса все заполняем минусами. из условия 4 исходим из того, что вишня у нас растет не на юге, значит ни груша, ни слива не растут на севере. тогда для сливы остаётся место только на юге, а для яблони, соответственно, на севере. север - яблоня, восток - вишня, юг - слива, запад - груша. ответ: явсг
alex-kuzora4411

using system;

using system.collections.generic;

using system.linq;

using system.text;

 

namespace consoleapplication1

{

      class program

      {

              static void main(string[] args)

              {

                      //задана последовательность из n вещественных чисел. определить сколько среди них меньших k, больших k, равных k.

                      console.writeline("введи k");

                      double k = double.parse(console.;

                      console.writeline("введи n");

                      double n = double.parse(console.;

                      console.writeline("введи числа");

                      double a = 0.0, n_min = 0.0, n_rav = 0.0, n_max = 0.0;

                      for (int i = 0; i < n; i++)

                      {

                              a = double.parse(console.;

                              if (a < k)

                                      n_min++;

                              else

                              {

                                      if (a == k)

                                              n_rav++;

                                      else

                                              n_max++;

                              }

                      }

                      console.writeline("меньших k - " + n_min + ", равных - " + n_rav + ", больших - " + n_max);

                      console.readkey();

              }

      }

}

 

   

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Номер 1 напечатать сумму элементов кратных одновременно двум или трем числового ряда 3, 6, 9, 2, 12, 2, 24 и 2 составить программу вычисления числового ряда для известного числа ряда n. y=(1-2/5)+(2+4/10)+(3-8/15)+(4+16/20)+
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

slastena69678
ИП Жанара
Vitproficosmetics
fucingprinces30
ismailovi670771
mariy-y34
Olesyamilenina8
Yurevich1291
alisabutusova
ren7869
verachus
perovd8111
tokarevaiv
infoproletarskay745
peresvetoff100015