assistant
?>

Написать программу в pascal abc для вычисления значений функции y(x)=x²+3 на промежутке от [0; 8] для целых значений x

Информатика

Ответы

zakupka-marion
Program n1;
var i: integer;
begin
for i:=0 to 8 do writeln('при x=',i,' y=',i*i+3);
end.
Воронина

Объяснение:

const nmax=15;

var a:array[1..nmax,1..nmax] of integer;

m,n,i,j,k,x,y:integer;

begin

randomize;

repeat

write('Количество строк до ',nmax,' n=');

readln(n);

until n in [1..nmax];

repeat

write('Количество столбцов до ',nmax,' m=');

readln(m);

until m in [1..nmax];

k:=-1;

for j:=1 to m do

begin

y:=1;

x:=j;

while(x>0) and(y<=n) do

begin

k:=k+1;

a[y,x]:=k;

x:=x-1;

y:=y+1;

end;

end;

for j:=2 to n do

begin

y:=j;

x:=m;

while(x>0)and(y<=n) do

begin

k:=k+1;

a[y,x]:=k;

x:=x-1;

y:=y+1

end;

end;

for i:=1 to n do

begin

for j:=1 to m do

write(a[i,j]:4);

writeln

end;

readln

end.

Переведите на Питон, в Паскале давно не работал

alisabutusova
1. Определим объем памяти, который занимает одна страница.
Символ текста кодируется 16 битами или 16/8=2 байтами. 1024 символа займут 1024х2=2048 байт. Рисунок состоит из 256х128=32768 точек, а цвет каждой точки кодируется 16 битами или 16/8=2 байтами. Следовательно, рисунок займет 32768х2=65536 байт.
Итого страница займет 2048+65536=67584 байт
2. Определим объем книги.
В книге 512 страниц, поэтому её объем составит 512х67584=34603008 байт.
Используем для ответа более крупные единицы.
34 603 008 /  1 024 = 33 792 Кбайта
33 792 / 1024 = 33 Мбайта
ответ: книга имеет объем 33 МБ

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Написать программу в pascal abc для вычисления значений функции y(x)=x²+3 на промежутке от [0; 8] для целых значений x
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

voen-torg
olyafom1234
Диана-Николаевна377
Nv-444
menesmir
yulyaderesh
Вера1072
Тресков946
tanysha1990
eliteclassic308
adel25159
dmitrij-sp7
olesya-cat8601
levsha-27509
borisrogovpr3407