antoska391
?>

Вмассиве из 10 целых чисел подсчитать количество элементов меньше чем среднее арифметическое минимального н максимального элементов. написать программу в delphi7

Информатика

Ответы

melnik-738
  var mas:array[0..9] of integer; 
 i,max,min,k:integer;
  arifm:real;
begin 
k:=0;
arifm:=0; 
 Randomize;
  for i:=0 to 9 do
  mas[i]:=Random(15);
  for i:=0 to 9 do 
 write(mas[i],'  '); 
 {poisk max} 
   max:=mas[0];
     for i:=1 to 9 do 
    if max<mas[i] then 
    max:=mas[i]; 
     {poisk min} 
   min:=mas[0]; 
   for i:=1 to 9 do 
    if min>mas[i] then 
    min:=mas[i];
     arifm:=(max+min)/2; 
    writeln('max: ',max); 
   writeln('min: ',min); 
    writeln('arifm: ',arifm:0:3); 
   for i:=0 to 9 do 
   if mas[i]<arifm then 
    inc(k); 
   writeln('k: ',k);
  readln;
end.
mkrtchyananaida6995

Во время ВОВ сложные технические и криптографические средства зашиты информации стали во многом ключевыми, ведь ценность информации возросла кратно. К июню 1941, когда немецкие армии вторглись на территорию СССР, наша система защиты государственной тайны была практически полностью сформирована. Она успешно выполняла целый ряд поставленных перед ней задач. От любых иностранных разведок надежно защищались все информационные ресурсы: мобилизационные, технические, военные, политические, идеологические и природные.

zipylin

Объяснение:

1)У тебя спрашивают b=1? У тебя дано b=3, значит b!=1. Если нет, то переходим к следующим указаниям: с=с-b=4-3=1, b=b+c=3+1(Потому что в предыдущем шаге мы дали новое значение для c, вернее произвели математическую операцию с ним. Возвращаемся(Слева линия) снова к логическому условию. Я честно говоря ХЗ, что они тут имели ввиду, но после того, что я описал c=1,но если мы продолжим проверку b=1, то c начнет принимать отрицательные значения. Цикл вышел, как мне кажется.

Теперь мне лень расписывать - держи фото/скрины

Не знаю, что у тебя за язык программирования, но я сделал тоже самое на Python, вроде результат отличатся не должен.


Здравствуйте решить контрольную по информатике Здравствуйте решить контрольную по информатике
Здравствуйте решить контрольную по информатике Здравствуйте решить контрольную по информатике

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Вмассиве из 10 целых чисел подсчитать количество элементов меньше чем среднее арифметическое минимального н максимального элементов. написать программу в delphi7
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

Azarenkoff
mishagoride885
Окунева-Мотова
rpforma71189
bruise6
remontsalarievo2
Андреевич-Екатерина1974
gabramova
Ivanovich_Kostik898
djevgen
colus77
pokupatel688
Ivanovich_Kostik898
angelina-uj1350
amaraks67