Khlistova1488
?>

Вс++ составить программу нахождения числа строк матрицы а(6, 6), максимальный элемент которых больше р

Информатика

Ответы

sochi-expert
#include <iostream>
using namespace std;

int main() {
  const int S = 6;
  int matrix[S][S];
  cout << "Введите матрицу построчно, разделяя пробелами: " << endl;
  for (int i = 0; i < S; i++) {
    for (int j = 0; j < S; j++) {
      cin >> matrix[i][j];
    }
    cout << endl;
  }
  int p;
  cout << "p = ";
  cin >> p;
  int count = 0, max;
  for (int i = 0; i < S; i++) {
    max = matrix[i][0];
    for (int j = 1; j < S; j++) {
      if (matrix[i][j] > max) max = matrix[i][j];
    }
    if (max > p) count++;
  }
  cout << endl << "ответ: " << count;
  return 0;
}
o-pavlova-8635
Const
  n = 20;

var
  x: array[1..n] of integer;
  i: integer;

begin
  Randomize;
  Writeln('*** Исходный массив ***');
  for i := 1 to n do
  begin
    x[i] := Random(101) - 50;
    Write(x[i]:4);
  end;
  Writeln;
  Writeln('*** Результирующий массив ***');
  for i := 1 to n do
  begin
    if (x[i] mod 2) = 0 then x[i] := 0;
    Write(x[i]:4);
  end;
end.

Тестовое решение:
*** Исходный массив ***
  -4  -8  42  18  -4 -19 -35  21  19  32 -45  45 -43 -22 -17 -12  11   9 -47  37
*** Результирующий массив ***
   0   0   0   0   0 -19 -35  21  19   0 -45  45 -43   0 -17   0  11   9 -47  37
Городничий_Коновалова384
Система счисления значит, что число, являющееся основанием это 1 десяток. То есть в 8 с.с числа 8 нет => 7+1 = 10 в 8 с. с. Для чисел, символов которых нет, используются буквы латинского алфавита. A(10), B(11) и т. д...

Решение:

Постепенно делим на два и записываем остаток
135 1
67 1
33 1
16 0
8 0
4 0
2 0
1
Записываем снизу вверх и получаем 10000111 в двоичной системе счисления

То же самое для восьмеричной, но делим на 8:
135 7
16 0
2
Получаем 207 в восьмеричной с. с.

Теперь... да, в шестнадцатеричной.
135 7
8
Получилось 87.

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Вс++ составить программу нахождения числа строк матрицы а(6, 6), максимальный элемент которых больше р
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

ivanpetrovichru1801
mail66
bg1967bg
iamhrusha
АлександрАнатолий
Геннадьевна
evsyukov1997
Shishkinaanasta1997
АнтонАртем
gunel1988alieva
MaratФам
edvlwork15
elvini857
Zolotnik974620
Dubovitskayae