rakitinat8
?>

С++ напишите программу, которая вводит два вещественных числа (x и y) и вычисляет значение x^y.

Информатика

Ответы

marat7
#include <iostream>

int main()
{
    float x, y;
    float res = 1;
    std::cin >> x >> y;
    for (int i = 0; i < y; i++)
        res *= x;
    std::cout << res << std::endl;
}
vantoslaltd
function Power(x,y:real):real;
{ (C) Puporev }
begin   if x=0 then     Power:=0  
else    
if x>0 then      
 Power:=exp(ln(x)*y)  
  else      
 Power:=-exp(ln(abs(x))*y);
end;
  var  x,y:real;
begin
 readln(x,y);
 writeln(power(x,y));
end.
Zhamynchiev
1. 128, так как 2^7 = 128, то есть семью битами можно закодировать 128 разных вариантов.

2. Черно-белое изображение без градаций - это два цвета (черный и белый). Глубина цвета - 1 бит, так как одним битом можно закодировать два варианта. 50*50 = 2500 бит, 2500/8 = 312,5 = 313 байт.

3. Определим глубину цвета, для этого разделим объем на количество пикселей.
(3*1024*8 бит) / (128*64) = (3*2^10*2^3) / (2^7*2^6) = 3 бита.
Тремя битами можно закодировать 8 цветов, т.к. 2^3=8

4. Палитра состоит из 64 цветов, значит глубина цвета равна 6 битам, т.к. 2^6 = 64. Объем в килобайтах будет равен
(32*128*6) / (8*1024) = (2^12 * 6) / 2^13 = 6 * 2^(-1) = 3 Кбайт
info46
1. Количество цвета N=2^i, где i - глубина цвета
N=2^4 N=16
ответ: 16 цветов

2. Объем видеопамяти 1 страницы = количество пикселей*глубину цвета
Глубину цвета i определим из формулы N=2^i, где N-количество цветов
16=2^i
i=4
Тогда объем видеопамяти= 640*350*4= 896000 бит
Так как страниц 2, то полученное значение умножим на 2
896000*2= 1792000 бит = 218,75 Кбайт
ответ: 218,75 Кбайт

3. Информационный объем изображения = количество пикселей*глубину цвета
Глубину цвета i определим из формулы N=2^i, где N-количество цветов
Черно-белое изображение имеет 2 цвета
2=2^i
i=1
Объем изображения= 10*10*1= 100 бит
ответ: 100 бит

4. Информационный объем изображения = количество пикселей*глубину цвета
Глубину цвета i определим из формулы N=2^i, где N-количество цветов
256=2^i
i=8
Объем изображения= 10*10*8= 800 бит

ответ: 800 бит

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

С++ напишите программу, которая вводит два вещественных числа (x и y) и вычисляет значение x^y.
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

rudakovam198
Васильевна Владимирович
arturcristian
daverkieva568
apro3444595
gumirovane2294
anastasiya613
Шеина
annashaykhattarova1
Dms161964937
atenza3736
vasiliiparshin7668
Болеславовна
Александр Елена1290
Александр Сергей
▲