astenSA
?>

Написать программу, которая вводит натуральное число и выводит следующее меню: введите номер : 1-вычисление квадратного корня; 2-возведение в квадрат; 3-вычисление синуса; 4-вычисление косинуса; программа должна выполнить , номер которого будет введён.

Информатика

Ответы

liza04521160
Var x:real; n:integer;
begin
write('x = ');
readln(x);
writeln('Введите номер задачи:');
writeln('1-вычисление квадратного корня;');
writeln('2-возведение в квадрат;');
writeln('3-вычисление синуса;');
writeln('4-вычисление косинуса;');
readln(n);
case n of
 1: writeln(sqrt(x):6:4);
 2: writeln(x*x:6:4);
 3: writeln(sin(x):6:4);
 4: writeln(cos(x):6:4);
 else writeln('Ошибка ввода');
end;
end.

Пример:
x = 2.1
Введите номер задачи:
1-вычисление квадратного корня;
2-возведение в квадрат;
3-вычисление синуса;
4-вычисление косинуса;
3
0.8632
agaloan8
#include <iostream>
#include <cmath>

int main()
{
    int x;
    std::cin >> x;
    std::cout << "Введите номер задачи: " << std::endl;
    std::cout << "1 - вычисление квадратного корня;" << std::endl;
    std::cout << "2 - возведение в квадрат;" << std::endl;
    std::cout << "3 - вычисление синуса;" << std::endl;
    std::cout << "4 - вычисление косинуса." << std::endl;
    int c;
    std::cin >> c;
    switch (c)
    {
    case 1:
        std::cout << sqrt(x) << std::endl;
        break;
    case 2:
        std::cout << x*x << std::endl;
        break;
    case 3:
        std::cout << sin(x) << std::endl;
        break;
    case 4:
        std::cout << cos(x) << std::endl;
        break;
    default:
        break;
    }
    std::cout << std::endl;
}
AndrukhovichKonovalov

Государственные органы выполняют распорядительные функции по отношению к подчиненным и исполнительные — по отношению к вышестоящим организациям и лицам. В широком смысле слова распорядительно-исполнительные отношения и функции организаций составляют понятие «администрация».

В узком смысле слова под администрацией подразумевается группа официальных лиц (орган), осуществляющая руководство учреждением, организацией, предприятием.

Руководящие работники документируют исполнение своих полномочий, т. е. оформляют свои действия соответствующими документами.

Документирование управленческой деятельности заключается в записи по установленным формам необходимой для управления информации, т.е. в создании документов. Основанием для создания документов является необходимость удостоверения наличия и содержания управленческих действий, передачи информации, хранения и использования ее в течение определенного времени.

Оформленные и удостоверенные в установленном порядке документы являются официальными документами. Одним из важнейших вопросов, решаемых при оформлении официальных документов, является придание документам юридической силы.

Юридическая сила документа — это свойство официального документа, сообщаемое ему действующим законодательством, компетенцией издавшего его органа и установленным порядком оформления.

Важно помнить, что при оформлении каждого документа следует придерживаться рекомендаций ГОСТ Р 6.30—2003 к наличию, размерам площадей, размещению и правильному оформлению всех необходимых для конкретного вида документа реквизитов.

Объяснение: На думаю

ravshandzon3019835681

Объяснение:

ов посимвольно в массив А[N]. Определить, является ли данное слово палиндромом (то есть одинаково читается как слева направо, так и справа налево).

C++Выделить код

1

2

3

4

5

6

7

8

9

10

11

12

13

14

15

16

17

18

19

20

21

22

23

24

25

26

27

28

29

30

31

32

33

34

35

36

#include <iostream>

#include <clocale>

int main()

{

setlocale(0, "");

std::cout << "Введите количество символов в слове A: n= ";

int n; // количество символов с слове

std::cin >> n;

//std::cout << "Введите символы в слове A:\n";

char* a = new char[n + 1]; // массив для символов, слово

for (int i = 0; i < n; i++)

{

std::cout << "A[" << i << "]= ";

std::cin >> a[i];

}

a[n] = '\0'; // добавляем символ конца строки

// Проверяем, является ли слово палиндромом

int i = 0;

while (i < n / 2 && a[i] == a[n - i - 1])

{

i++;

}

std::cout << "Ваше слово '" << a << "' ";

if (i == n / 2)

{

std::cout << "является палиндромом.\n";

}

else

{

std::cout << "не является палиндромом.\n";

}

// Освобождаем динамическую память

delete[] a;

system("pause");

}

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Написать программу, которая вводит натуральное число и выводит следующее меню: введите номер : 1-вычисление квадратного корня; 2-возведение в квадрат; 3-вычисление синуса; 4-вычисление косинуса; программа должна выполнить , номер которого будет введён.
Ваше имя (никнейм)*
Email*
Комментарий*