КараханянКусков
?>

Решето эратосфена в pascalabc данные вводятся с клавиатуры или из файла input.txt, выводятся на экран или в файл output.txt. первые тесты не всегда с примерами из условия. напишите программу, которая выводит все простые числа в диапазоне от 2 до n включительно ( 2 ≤ n ≤ 100000 входные данные входная строка содержит целое число n ( 2 ≤ n ≤ 100000 ). выходные данные программа должна вывести все простые числа в диапазоне от 2 до n в одну строку, разделив их пробелами. примеры входные данные : 20 выходные данные : 2 3 5 7 11 13 17 19

Информатика

Ответы

rn3ay8
Program n1;
var n,i: longint;
function simply(a: longint ):boolean;
var i: longint;
begin
simply:=true;
for i:=2 to trunc(sqrt(a)) do begin if a mod i=0 then begin
simply:=false;
break
end
end
end;
begin
readln(n);
for i:=2 to n do if simply(i) then write(i,' ');
end.
galustyanvitaly4842
// PascalABC.NET 3.0, сборка 1073
var
  a,b,c:integer;
begin
  Write('Введи a,b,c: '); Read(a,b,c);
  if (a=b) or (a=c) or (b=c) then Writeln('Есть пара одинаковых')
  else Writeln('Все числа различные')
end.

Тестовое решение:
Введи a,b,c: 6 3 -12
Все числа различные

Введи a,b,c: 5 -4 5
Есть пара одинаковых

// PascalABC.NET 3.0, сборка 1073
var
  n:string;
  a,b:char;
begin
  Write('Введи натуральное число n: '); Readln(n);
  Write('Введи подряд пару разыскиваемых цифр: '); Read(a,b);
  if Pos(a,n)>0 then Writeln('В числе есть цифра '+a)
  else Writeln('В числе цифры '+a+' нет');
  if Pos(b,n)>0 then Writeln('В числе есть цифра '+b)
  else Writeln('В числе цифры '+b+' нет')
end.

Тестовое решение:
Введи натуральное число n: 3141592653589793
Введи подряд пару разыскиваемых цифр: 47
В числе есть цифра 4
В числе есть цифра 7

// PascalABC.NET 3.0, сборка 1073
var
  i,n:integer;
  fiba,fibb,fib:longint;
begin
  Write('Введи натуральное число (1-46): '); Read(n);
  if n<3 then Writeln('Число Фибоначчи равно 1')
  else begin
    fiba:=1; fibb:=fiba;
    for i:=3 to n do begin
      fib:=fiba+fibb;
      fiba:=fibb; fibb:=fib
    end;
    Writeln('Число Фибоначчи равно ',fib)
  end
end.

Тестовое решение:
Введи натуральное число (1-46): 13
Число Фибоначчи равно 233
iv1as2
Наука Науки бывают разные. Есть батаника астрономия и т. д. Каждая наука изучает что-то. Например батаника изучает растения. Я думаю что очень интересно изучать какую нибудь науку! Образование Мне кажется что образование нужно каждому. Каждый человек должен быть образованным. Для этого нужно ходить в школу. Закончить 9-11 классы и пойти на работу. Культура Тебе наверно известно слово культура. Мне кажется что все люди должны быть культурными. Но к сожалению не все люди могут быть культурными. С культурным человеком приятно общаться.

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Решето эратосфена в pascalabc данные вводятся с клавиатуры или из файла input.txt, выводятся на экран или в файл output.txt. первые тесты не всегда с примерами из условия. напишите программу, которая выводит все простые числа в диапазоне от 2 до n включительно ( 2 ≤ n ≤ 100000 входные данные входная строка содержит целое число n ( 2 ≤ n ≤ 100000 ). выходные данные программа должна вывести все простые числа в диапазоне от 2 до n в одну строку, разделив их пробелами. примеры входные данные : 20 выходные данные : 2 3 5 7 11 13 17 19
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

Svetlana1335
milenaochirova01017424
Vyacheslavovich-Gubanov
Ивановна_Маликова1549
a60ikurgannikova
belka1976
Иванова
ilyushin-e
alekbur
kassel1b
ostapbender1111
tat122
Olga1233
xachen
Татьяна Гришаевич