chizhenkovd9
?>

Дано натуральное число n. напишите программу ддя вычесленния суммы 1/1 + 1/2 + 1/3+ .. + 1/n

Информатика

Ответы

svetsalikowa
Program n1;
var n,i: integer;
sum: real;
begin
sum:=0;
readln(n);
for i:=1 to n do sum:=sum+1/i;
write(sum);
end.
tanyashevvvv
// PascalABC.NET 3.1, сборка 1179 от 29.02.2016
procedure GetProdNeg(a:array of integer; var p:real);
// произведение отрицательных элементов
begin
  p:=a.Where(x->x<0).Aggregate(1.0,(p,e)->p*e)
end;

function IsPrime(n:integer):boolean:=
  Range(2,Round(sqrt(n))).All(i->n mod i<>0);

procedure ArrPrime(n:integer; var a:array of integer);
// массив простых чисел не больших n
begin
  a:=Range(2,n).Where(i->IsPrime(i)).ToArray
end;

begin
  var n:=ReadInteger('n=');
  var a:=ArrRandom(n,-50,50); a.Println;
  var r:real;
  GetProdNeg(a,r);
  Writeln('Произведение ',r);
  n:=ReadInteger('n=');
  var b:array of integer;
  ArrPrime(n,b);
  b.Println
end.

Тестовое решение:
n= 15
27 -7 -36 40 -15 -21 -47 -28 -12 45 3 -38 -15 1 -39
Произведение 27866837980800
n= 300
2 3 5 7 11 13 17 19 23 29 31 37 41 43 47 53 59 61 67 71 73 79 83 89 97 101 103 107 109 113 127 131 137 139 149 151 157 163 167 173 179 181 191 193 197 199 211 223 227 229 233 239 241 251 257 263 269 271 277 281 283 293
Vadim443
Максимальное число, составленное из утроенного произведения цифр  будет 
9*3*N  -  не  может быть больше 54,  т.е.  
N может быть только 1 или 2.  По условию х>=10  ->  N=2  (N -порядок числа).
Поэтому искать нужно среди чисел от 11 до 54.  Решение - число 15.

var n,m: integer;
begin
  write('n = ');  readln(n);
  if n=2 then
  begin    m:=11;
    repeat
      if (m mod 10)*(m div 10)*3=m then
      begin
        writeln('число:  ',m);
        m:=55;
      end;
      m:=m+1;
    until m>54;
  end
  else  writeln('нет решения');
end.

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Дано натуральное число n. напишите программу ддя вычесленния суммы 1/1 + 1/2 + 1/3+ .. + 1/n
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

Olga1233
milkamilka1998
kmr495270
gurman171
apioslk4533
dvpered
praktikadok
Анатольевич-Митюшин
Panda062000
Lusiarko65
Троцкая-Ивановна
guzelda19904850
dmitrijku
Голосова-Лобанов1555
Васильевичь Виктория457