РоманТрофимов2012
?>

Число цукамерна - натуральное число, которое делится на произведение своих цифр, например 175 делится на 1*7*5=35. составить программу, которая выводит на экран все трёхзначные числа цукамерна. !

Информатика

Ответы

Геннадьевна Вета560
Var k,a,b,c,l:integer;
begin
readln(k);
a:=k div 100;
b:=k div 10 mod 10;
c:=c mod 10;
l:=a*b*c;
if (k mod l=0) then writeln(k);
end.
Levinalx4938
А) v = d * t * i * k v - информационный объем файла d - частота дискретизации t - время звучания i - глубина кодирования 1 сигнала k - количество каналов d1 = 8 кгц = 8000 гц t = 1 мин = 60 секунд k = 1 канал (моно-) i1 = 16 бит = 2 байта v1 = 8000 гц  * 60 c * 2 байта * 1  =  960000 байт =  937,5 килобайт = 0,91 мегабайт - информационный объем 1 звукового файла d2 = 24 кгц = 24000 гц t = 1 мин = 60 секунд k = 1 канал (моно-) i2 = 16 бит = 2 байта v2 = 24000 гц  * 60 c * 2 байта * 1 =  2880000 байт =  2812,5 килобайт =  2,75 мегабайт -  информационный объем 2 звукового файла детская песня - колыбельная медведицы - 2,09 мегабайт меньше 2 объема на 0,66 мб и больше 1 объема на 1,18 мб песня валентины толкуновой тебя любила - 1,05 мб больше 1 объема на 0,14  мб, меньше второго объема на 1,7 мб
GridnevaVNIGNI"

ответ:

объяснение:

если я все правильно понял:

#include "pch.h"

#include

using namespace std;

int main()

{

setlocale(null, "rus");

double a[100];

int n;

cout < < "введи количество элементов массива: "; cin > > n;

cout < < "введи элементы массива: " < < endl;

for (int i = 0; i < n; i++)

  cin > > a[i];

double s = 0;

int fznach, sznach;

for (int i = 0; i < n; i++)

{

  if (a[i] == 0)

  sznach = i;

}

for (int i = n-1; i > = 0; i--)

{

  if (a[i] == 0)

  fznach = i;

}

for (int i = fznach; i < sznach; i++)

  s = s + a[i];

cout < < " искомая сумма равна: " < < s < < endl;

return 0;

}

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Число цукамерна - натуральное число, которое делится на произведение своих цифр, например 175 делится на 1*7*5=35. составить программу, которая выводит на экран все трёхзначные числа цукамерна. !
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

Иванникова736
lepekhov4011
gdmaslo
ivanda
Galinagol559
evamining
gr1schinanata
kol-nat26
tatianamatsimoh
Николаевич-Анатольевич599
zazaza74
Максим
zorinka777
lukanaft
artashhovhan