deniskotvitsky56
?>

Написать программу на с++ 3. известен факториал числа (вводится с клавиатуры найти это число.

Информатика

Ответы

makscska22879
1.
#include <iostream>
using namespace std;

int main()
{
    int f, n, p;
    cin >> f;
    n = 0;
    p = 1;
    while (p<f) {
    n++;
    p*=n;
    }
    if (p==f) cout << n;
    else cout << "Ошибка ввода";
    system("pause");
}

2.
#include <iostream>
using namespace std;

int main()
{
    int f, n, p;
    cin >> f;
    p = 1;
    for (n=1; p<f; n++) p*=n;
    if (p==f) cout << n-1;
    else cout << "Ошибка ввода";
    system("pause");
}

Пример:
120
5
vdnh451

3.    15

4.    4) ⌐A & ⌐B

Объяснение:

3.

y = 1        x = 11

пока условие x > 0 истинно (да) выполняется цикл

Действия в цикле:

1) x = x - 3

2) y = y + x

y = 1        x = 11

11 > 0       (да) выполняется цикл

Действия в цикле:

1) x = x - 3  = 11 - 3 = 8

2) y = y + x  = 1 + 8 = 9

y = 9        x = 8

8 > 0       (да) выполняется цикл

Действия в цикле:

1) x = x - 3  = 8 - 3 = 5

2) y = y + x  = 9 + 5 = 14

y = 14        x = 5

5 > 0       (да) выполняется цикл

Действия в цикле:

1) x = x - 3  = 5 - 3 = 2

2) y = y + x  = 14 + 2 = 16

y = 16        x = 2

2 > 0       (да) выполняется цикл

Действия в цикле:

1) x = x - 3  = 2 - 3 = -1

2) y = y + x  = 16 + (-1) = 16 - 1 = 15

y = 15        x = -1

-1 > 0       (нет) цикл  не выполняется

y = 15        x = -1

4.

Составим таблицу истинности для каждого выражения (смотри картинку)


Какое значение примет переменная y после выполнения фрагмента программы. Сделать трассировочную табл
annanas08

21

Объяснение:

y = 1       x = 10

пока условие  x > 0 истинно (да) выполнить

Действия в цикле:

x = x - 2

y = y + x

y = 1       x = 10

10 > 0   (да)

Действия в цикле:

x = 10 - 2  = 8

y = 1 + 8 = 9

y = 9       x = 8

8 > 0   (да)

Действия в цикле:

x = 8 - 2  = 6

y = 9 + 6 = 15

y = 15       x = 6

6 > 0   (да)

Действия в цикле:

x = 6 - 2  = 4

y = 15 + 4 = 19  

y = 19       x = 4

4 > 0   (да)

Действия в цикле:

x = 4 - 2  = 2

y = 19 + 2 = 21

y = 21       x = 2

2 > 0   (да)

Действия в цикле:

x = 2 - 2  = 0

y = 21 + 0 = 21

y = 21       x = 0

0 > 0   (нет)

Цикл не выполняется

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Написать программу на с++ 3. известен факториал числа (вводится с клавиатуры найти это число.
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

Ваган Шутова332
lagutkins
yocrew13
ЮлияДаниил520
Yurevna-Anatolevna
eronch
olga0909196323
qwqwweqw3
l250sp70
Gennadevna_Baidalina131
sve-lysenko
makscska22879
euzdenova
Viktorovna
Чубкова1290