Mukhina1811
?>

Написать программу :Если Х принадлежит отрезку [-2, 5], то вывести сообщение "X принадлежит", Если Х не принадлежит отрезку [-2, 5], то вывести сообщение "X принадлежит"(использовать логические операции)​

Информатика

Ответы

sashulyah3183
Задача, аналогичная той, которую публиковали вчера. Только цикл repeat заменяем на while.

Сначала немного математики.
\displaystyle a_n= \frac{n!}{(2n)!}=\frac{\prod_{i=1}^ni}{\prod_{i=1}^{2n}i}=\frac{\prod_{i=1}^ni}{\prod_{i=1}^{n}i\times\prod_{i=n+1}^{2n}i}=\frac{1}{\prod_{i=n+1}^{2n}i}; \quad n\in\mathbb N
О модуле тут смысла нет говорить, поскольку все an - суть положительные величины на интервале (0;1).

uses Crt;

function ai(n:integer):real;
var
  i:integer;
  p:real;
begin
  p:=1;
  for i:=n+1 to 2*n do p:=p*i;
  ai:=1/p
end;

var
  i:integer;
  eps,s,an:real;
begin
  ClrScr;
  Write('eps='); Read(eps);
  s:=0; i:=1; an:=eps+1;
  while an>=eps do begin
     an:=ai(i);
     if an>=eps then begin s:=s+an; Inc(i) end
  end;
  Writeln('s=',s);
  ReadKey
end.

Тестовые решения:
eps=0.07
s= 5.8333333333E-01

eps=0.000001
s= 5.9229647667E-01

eps=1e-8
s= 5.9229653448E-01

Для контроля результата можно отметить, что сумма первых 1000 членов ряда равна приблизительно 5.922965365Е-01

Если раздражает наличие функции, можно и без нее:
uses Crt;

var
  i,j:integer;
  eps,s,an,p:real;
begin
  ClrScr;
  Write('eps='); Read(eps);
  s:=0; i:=1; an:=eps+1;
  while an>=eps do begin
    p:=1;
    for j:=i+1 to 2*i do p:=p*j;
    an:=1/p;
    if an>=eps then begin s:=s+an; Inc(i) end
  end;
  Writeln('s=',s);
  ReadKey
end.
sav4ukoxana7149
1)            находим количество пикселей, используя для вычисления степени числа 2: n  = 512 · 256 = 29  · 28  = 217 2)            объём файла в  кбайтах  64 = 26 3)            объём файла в битах  26    · 213  = 219 4)            глубина кодирования (количество битов, выделяемых на 1 пиксель): 219  :   217  = 22  = 4 бита на пиксель 5)            максимальное возможное количество  цветов 24  = 16 6)            ответ:   16.

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Написать программу :Если Х принадлежит отрезку [-2, 5], то вывести сообщение "X принадлежит", Если Х не принадлежит отрезку [-2, 5], то вывести сообщение "X принадлежит"(использовать логические операции)​
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

Nekrasova
evge-borisova2
euzdenova
КараханянКусков
billl24
postbox
sales5947
artemkolchanov24
keti0290103
filial2450
heodbxbbshe
juli19657
Наталья Юрьевич1228
inris088
игнатова_Сергей1228