ldstroy
?>

Составьте программу на Паскале, вычисляющую сумму всех четных натуральных чисел от 234 до 278

Информатика

Ответы

olkay
1. Программа "Анкета":
program anketa;
var a,b,d:string;
c:char;
begin
writeln('Введите ваши имя и фамилию в именительном падеже: ');
readln(a,b);
writeln('Введите букву класса: ');
readln(c);
writeln('Введите ваше хобби: ');
readln(d);
writeln('Меня зовут ',a,' ',b,';');
writeln('Я учусь в 7 "',c,'" классе гимназии 524;');
writeln('Моё хобби - ',d,';');
writeln('Периметр прямоугольника равен 30');
writeln('Сегодня ярко светит солнце!')
end.
2. Программа "Опросы":
program oprosy;
var a,b,c:integer;
d:real;
begin
writeln('Введите ваши оценки по пятибалльной шкале: ');
readln(a,b,c);
d:=(a+b+c)/3;
writeln('Ваша средняя оценка за тесты - ',d,'.');
end.
3. Программа "Периметр прямоугольника":
program perimetr;
var a,b,c:integer;
begin
writeln('Введите стороны прямоугольника: ');
readln(a,b);
c:=(a+b)*2;
writeln('Периметр прямоугольника = ',c,'.');
end.
Ivanovich_Kostik898
1. Современное решение

PascalABC.NET 3.2, сборка 1417 от 28.03.2017
Внимание! Если программа не работает, обновите версию!

begin
  var n:=ReadInteger('Введите двухзначное число:');
  Writeln('Максимальная цифра ',max(n div 10, n mod 10))
end.

2. Школьное решения уровня ТурбоПаскаль 1983г.

var
  n,d,e,max:integer;
begin
  Write('Введите двухзначное число: ');
  Read(n);
  d:=n div 10;
  e:=n mod 10;
  if d>e then max:=d
  else max:=e;
  Writeln('Максимальная цифра ',max)
end.

3. Пример работы обоих программ (одинаковый)

Введите двухзначное число: 37
Максимальная цифра 7

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Составьте программу на Паскале, вычисляющую сумму всех четных натуральных чисел от 234 до 278
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

turovvlad
Ivan1568
Надежда-Андрей930
arturcristian
kolgatin69
Сергеевна_Юрикович
гайсанов
len22
Ольга Сергей1822
amramzi
Yelena Dilyara
vasavto1
osnovnoisklad3551
leobashkurov1089
gudachaa1480
▲