ievlevasnezhana7
?>

Нужно написать программу на языке паскаль. дан массив действительных чисел среди них есть равные. найти первый максимальный и заменить его нулём

Информатика

Ответы

info32
PascalABC.NET 3.4.2, сборка 1837 от 11.10.2018Внимание! Если программа не работает, обновите версию!

begin

 var a := ReadArrReal(ReadInteger('n='));

 a[a.IndexMax] := 0;

 a.Println

end.

n= 10-14.75 -62.2 20.7 53.01 -28.25 18.04 29.35 -29.21 53.01 -63.53-14.75 -62.2 20.7 0 -28.25 18.04 29.35 -29.21 53.01 -63.53
evsyukov1997
Var
    a: array[1..10]of integer;
    i, k, n: integer;

begin
    Writeln('Исходный массив:');
    Randomize;
    for i := 1 to 10 do
    begin
        a[i] := Random(51) - 25;
        Write(a[i], ' ');
    end;
    Writeln;
    
    n := 0;
    k := 0;
    for i := 10 downto 1 do
        if a[i] > 0 then
        begin
            k := k + 1;
            if k = 2 then n := i;
        end;
    
    if k = 0 then
        Writeln('В массиве нет положительных элементов!')
    else
        Writeln('Предпоследний положительный элемент: a[', n, '] = ', a[n]);
    
    Readln;
end.
Сайжанов
Var A : array [1..4, 1..4] of integer ;
i,j, p,k: integer ;
Begin
  randomize;
  k:=1; p:=1;
  For i:=1 to 4 do
  Begin
    For j:=1 to 4 do
    Begin
      A[i,j]:=random (100);
      if A[i,j]>A[k,p] then
      begin
        k:=i;
        p:=j;
      end;
      Write(A[i,j]:3);
    end;
    Writeln;
  end;
 
  writeln ('Максимальный элемент матрицы = ', A[k,p]);
  write ('Он находится в строке №' , k);
  writeln (' и в столбце №' , p);
  Writeln('Меняем максимальный элемент матрицы и первый элемент первой строки:');
  i:=A[k,p];
  A[k,p]:=A[1,1];
  A[1,1]:=i;
  For i:=1 to 4 do
  Begin
    For j:=1 to 4 do Write(A[i,j]:3);
    Writeln;
  end;
end.

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Нужно написать программу на языке паскаль. дан массив действительных чисел среди них есть равные. найти первый максимальный и заменить его нулём
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

Стефаниди
Irina Svetlana
nikolai37
elmira01048775
igorSvetlana547
Borg Fedak1162
gsktae7
Нана_Елена
Kochinev7
iraira761
themolodoy
restkof
Sergei1805
imiryakubov