vitaliy
?>

"дана строка символов t. напишите программу, которая добавит перед и после каждой гласной буквой строки – букву ‘p’. например, ‘corectitudine’ станет ‘’. "написать на c++

Информатика

Ответы

Akvamontaz
#include <iostream>
#include <set>
 
using namespace std;
int main()
{
 string t, s="";
 cout << "t = ", cin >> t, cout << endl;
 set<char> a = {'a','e','i','o','u','y'};
 for(int i=0; i<t.length(); i++)
  if(a.find(t[i]) == a.end()) s = s+t[i];
  else s = s+'p'+t[i]+'p';
 cout << s << endl;
 return 0;
}

Пример:
t = corectitudine
Fedorova_79166180822
Существует три философские концепции информации: 1. Атрибутивная концепция. Информация является свойством всего сущего, всех материальных объектов мира. Информация — атрибут всех материальных объектов. 2. Функциональная концепция. Информация возникла вместе со Вселенной. Информация проявляется в воздействии одних объектов на другие, в изменениях, к котоым такие воздействия приводят. Информация — это атрибут, свойственный только живой природе. 3. Антропоцентрическая концепция. Информация существует лишь в человеческом сознании, в человеческом восприятии. Информационная деятельность присуща только человеку и происходит в социальных системах. Создавая информационную технику, человек создает инструменты для своей информационной деятельности
misie1974
Порядок неубывания,значит порядок возрастания.
2828 не может,так как если мы введём максимальное число 99999,то будет 2727
2512 не может, так как порядок возрастания,а 25>12
2518 не может, так как порядок возрастания,а 25>18
2524 не может, так как порядок возрастания,а 25>24
2425 может(число 78997)
1825 может(число 72979)
1225 может(число 12979)
123 не может,существует 2 варианта записи этого числа:
1)12 и 3,но такого быть не может,так как 12>3
2)1 и 23,но такого быть не может,так как чтобы получилось 23 должны быть числа больше 7,а 1 получается слева,значит среднее число максимум 1,но нам оно не подходит
Итак,подходят 2425,1825,1225
ответ: 3

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

"дана строка символов t. напишите программу, которая добавит перед и после каждой гласной буквой строки – букву ‘p’. например, ‘corectitudine’ станет ‘’. "написать на c++
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

Stasyadoma
daskal83
juliaWinter
anytkaakk
coleslow12
mmurzina
liza04521160
Alenachernika9111
m79857860146895
alexander4590
Vitalevich
tvshi
Александра-Андрей909
Test Станислав
dokmak140652