iqtoy2010
?>

Написать программу в pascal. задан двумерный массив c из 3-х строк и 5-и столбцов. составить программу, которая вычисляет произведение всех элементов массива. затем организовать новый массив с, в котором значения элементов, лежащих на главной диагонали, равны 1, а остальные элементы равны квадрату соответствующих элементов исходного массива с.

Информатика

Ответы

navi35374
// PascalABC.NET 3.3, сборка 1590 от 03.12.2017
// Внимание! Если программа не работает, обновите версию!

begin
  Writeln('*** Исходный массив ***');
  var c:=MatrRandom(3,5,-9,9);
  c.Println(4); Writeln(4*c.ColCount*'-');
  Writeln('Произведение элементов: ',
      c.ElementsByRow.Aggregate(int64(1),(x,y)->x*y));
  Writeln('*** Массив-результат ***');
  c.Transform(t->t*t);
  for var i:=0 to c.RowCount-1 do c[i,i]:=1;
  c.Println(4)
end.

Пример
*** Исходный массив ***
  -7  -3   4  -1  -5
   9   1   9   2   4
  -3  -3  -1  -4  -8

Произведение элементов: -78382080
*** Массив-результат ***
   1   9  16   1  25
  81   1  81   4  16
   9   9   1  16  64
Рудаков Бахтовар

const

   handsfree = false;

   nmax = 10;

   random_min = -50;

   random_max = 50;

var

   a: array[0..nmax] of real;

   i, n: integer;

   sum, x: real;

begin

   {ввод массива}

   n := nmax;

   if handsfree then begin

       for i := 0 to n do

       begin

           a[i] := random(random_max - random_min) + random_min;

           write(a[i], ' ');

       end

   end

   else begin

       for i := 0 to n do

           readln(a[i]);

   end;

   writeln();

   

   {подсчет суммы}

   write('x = ');

   readln(x);

   

   sum := a[n];

   for i := n - 1 downto 0 do

       sum := sum * x + a[i];

   writeln('S = ', sqrt(sum));

end.

coalajk
Я не спец по паскалю но вот на с++ ,думаю всё понятно будет

#include <bits/stdc++.h>
using namespace std;

int main() {
  vector <int> s;
 int i,sred,cis,sum=0;
 while(cin>>cis){
     s.push_back(cis);
 }
 for(i=0;i<s.size();i++){
     sum+=s[i];
 }
 sred=sum/s.size();
 cout<<sred<<endl;
    return 0;
}
Что мы делаем ,сейчас скажу.Сначала мы через while добавляем элементы в массив vector , затем находим сумму элементов массива . И чтобы найти ихнее среднее арифметическую мы делим сумму на количество элементов массива.

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Написать программу в pascal. задан двумерный массив c из 3-х строк и 5-и столбцов. составить программу, которая вычисляет произведение всех элементов массива. затем организовать новый массив с, в котором значения элементов, лежащих на главной диагонали, равны 1, а остальные элементы равны квадрату соответствующих элементов исходного массива с.
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

elenakarpova709
nestruev
Bi-1704
fedotochkin8
Anatolevich667
Yelena Dilyara
edvard-b
oksanamalakhova004610
mez-omts-d5
Vitalevna
marketing3
nekrasovaolga27
inainainainaina0073
oksit
Абдулганиева Сергей