Напишите программу языком бэйсик "напечатать таблицу соответствия между квадратными метрами и гектарами для значений от 0.5 га до 6.5 га с шагом 0.5га"
' Цикл While Dim GA as Double GA = 0.5 Do While GA <= 6.5 print GA, " га = "; GA * 10000, " квадратных метров" GA = GA + 0.5 Loop
' Цикл For Dim X as Double PRINT "X" , "Y" FOR X=0.5 TO 6.5 STEP 0.5 PRINT X , X*10000 NEXT
' For с двумя переменными Dim X as Double Dim Y as Double PRINT "X" , "Y" FOR X=0.5 TO 6.5 STEP 0.5 Y = X * 10000 PRINT X , Y NEXT
Svetlana1287
30.03.2023
1. "Школьное" решение
// PascalABC.NET 3.0, сборка 1073 const sb='bcdfgjklmnpqrstvwxz'; s='Computer programming is a process of computer programs creation'; var i,n:integer; s1,sn,t:string; begin i:=1; while s[i]<>' ' do Inc(i); s1:=Copy(s,1,i-1); n:=Length(s); i:=n; while s[i]<>' ' do Dec(i); sn:=Copy(s,i+1,n-i); t:=''; for i:=1 to Length(s1) do if Pos(s1[i],sb)>0 then t:=t+s1[i]; s1:=t; t:=''; for i:=1 to Length(sn) do if Pos(sn[i],sb)>0 then t:=t+sn[i]; sn:=t; t:=''; for i:=1 to Length(s1) do if Pos(s1[i],sn)>0 then if Pos(s1[i],t)=0 then t:=t+s1[i]; for i:=1 to Length(t) do Write(t[i],' '); Writeln end.
Тестовый прогон: t r
2. "Нормальное" решение
// PascalABC.NET 3.0, сборка 1073 const sb='bcdfgjklmnpqrstvwxz'; s='Computer programming is a process of computer programs creation'; begin var a:=s.ToWords(' '); a[0].Intersect(a[a.Length-1]).Where(x->Pos(x,sb)>0).Println(',') end.
Тестовый прогон: t,r
dimkimka386
30.03.2023
Var a:array of array of integer; c:array of array of integer; ma:array of array of integer; i,j,n:integer; begin; randomize; readln(n); setlength(a,n+1); //задаём размерность динамических массивов setlength(c,n+1); setlength(ma,n+1); for i:=1 to n do begin; setlength(a[i],n+1); setlength(c[i],n+1); setlength(ma[i],n+1); end;
writeln('Matrix A:'); //генерируем массив псеводслучайных чисел for i:=1 to n do begin; writeln; for j:=1 to n do begin; a[i,j]:=random(10); write(a[i,j]:4); end; end; writeln;
writeln('Matrix C:'); //аналогично for i:=1 to n do begin; writeln; for j:=1 to n do begin; c[i,j]:=random(10); write(c[i,j]:4); end; end;
for i:=1 to n do //сохраняем матрицу C для транспонации for j:=1 to n do ma[i,j]:=c[i,j]; writeln;
writeln('Transpose matrix C:'); //транспонируем C for i:=1 to n do begin; writeln; for j:=1 to n do begin; c[i,j]:=ma[j,i]; write(c[i,j]:4); end; end;
writeln; writeln('Final matrix:'); // получаем финальную матрицу for i:=1 to n do begin; writeln; for j:=1 to n do begin; ma[i,j]:=2*c[i,j]*a[i,j]; {по свойству дистрибутивности матриц С(A+A)=C*A+C*A=2*C*A} write(ma[i,j]:4); end; end; end.
Ответить на вопрос
Поделитесь своими знаниями, ответьте на вопрос:
Напишите программу языком бэйсик "напечатать таблицу соответствия между квадратными метрами и гектарами для значений от 0.5 га до 6.5 га с шагом 0.5га"
Dim GA as Double
GA = 0.5
Do While GA <= 6.5
print GA, " га = "; GA * 10000, " квадратных метров"
GA = GA + 0.5
Loop
' Цикл For
Dim X as Double
PRINT "X" , "Y"
FOR X=0.5 TO 6.5 STEP 0.5
PRINT X , X*10000
NEXT
' For с двумя переменными
Dim X as Double
Dim Y as Double
PRINT "X" , "Y"
FOR X=0.5 TO 6.5 STEP 0.5
Y = X * 10000
PRINT X , Y
NEXT