Олимов Протопопова
?>

Составить программу, которая получает новую строку, удалив из первоначальной строки третье слово

Информатика

Ответы

evolkova-73
// PascalABC.NET 3.3, сборка 1590 от 03.12.2017
// Внимание! Если программа не работает, обновите версию!

begin
  var a:=ReadlnString.ToWords; // читаем строку, образуем массив слов
  var s:=(a[:2]+a[3:]).JoinIntoString; // получаем новую строку
  Writeln(s) // вывод...
end.

Пояснения.
a - массив с индексами от 0 до n-1, где n - число слов.
Срез a[:2] возвращает последовательность элементов массива 0 и 1.
Срез a[3:] возвращает последовательность элементов массива, начиная с третьего и до конца массива. Объединение последовательностей порождает необходимый набор слов, который объединяется в строку через пробел при

Пример
А роза упала на лапу Азора
А роза на лапу Азора
elena-novikova-1992
Компью́терная мышь — координатное устройство для управления курсором и отдачи различных команд компьютеру. Управление курсором осуществляется путём перемещения мыши по поверхности стола или коврика для мыши. Клавиши и колёсико мыши вызывают определённые действия, например: активация указанного объекта, вызов контекстного меню, вертикальная прокрутка веб-страниц и электронных документов.

Получила широкое распространение в связи с появлением графического интерфейса пользователя на персональных компьютерах. Помимо мышек, встречаются другие устройства ввода аналогичного назначения: трекболы, тачпады, графические планшеты, сенсорные экраны. Такое подойдёт?
oksanamalakhova004610

Вот эти
- вставка таблицы – это проще всего. Здесь вы можете выбрать или ввести необходимое количество столбцов и строк, все они будут иметь одинаковую высоту и ширину, которую можно регулировать курсором. Кстати, вставлять таблицу можно и в уже существующую;
- нарисовать таблицу. В этом методе больше возможностей. Вы сможете разбивать отдельные столбцы и строки на части и делать таблицу более сложной. При переходе в режим рисования курсор принимает вид карандаша, который рисует только прямые линии;
- вставить таблицу из Excel. Так данный программный продукт предназначен именно для работы с таблицами, то разработчики интегрировали эти две программы для удобства пользователя;
- использовать готовый шаблон. Этот для любителей красоты в документе. Вы просто вставляете готовую таблицу с оформленным дизайном и редактируете ее под свои нужды.
Также не забывайте, что все приведенные можно использовать одновременно для создания и редактирования одной таблицы. И если при создании браузеров программисты Microsoft, по утверждению многих пользователей, халтурят, то здесь их обвинить не в чем, ведь по удобству и возможностям Word практически не имеет конкурентов среди текстовых редакторов.

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Составить программу, которая получает новую строку, удалив из первоначальной строки третье слово
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

Спиридонова
horina12
svetrusval
maxchemaxim14
alexeytikhonov
Irina1435
Владислав-Аветисян217
koxhulya61
Bella
Pogosyan Nataliya
Ushakova Sakhno
Galinagol559
Nadirovich1317
Gesper63
yusliva