anitanemtsewa
?>

Написать программу которая вводит с клавиатуры 5 дробных чисел и вычисляет их арифметическое используя цикл for

Информатика

Ответы

pechinin
C++
#include "stdafx.h"
#include "conio.h"
#include <iostream>

using namespace std;
int main()
{
setlocale(LC_ALL, "Russian");
const int n = 5;
float Arr[n], summ(0),sa;
cout << "Введите пять дробных чисел." << endl;
for (int i = 0; i < n; i++)
{
 cin >> Arr[i];
}
for (int j = 0; j < n; j++)
{
 summ += Arr[j];
}
sa = summ / n;
cout <<"Среднее арифметическое =" << sa;
_getch();   
 return 0;
}
Написать программу которая вводит с клавиатуры 5 дробных чисел и вычисляет их арифметическое использ
websorokin
// PascalABC.NET 3.0, сборка 1157 от 02.02.2016
begin
  var n:=ReadInteger('n=');
  if n<0 then Writeln(n,'! не определено: n<0')
  else
    if n=0 then Writeln('0!=1')
    else begin
      var p:BigInteger:=1;
      for var i:=2 to n do p*=i;
      Writeln(n,'!=',p)
      end
end.

Тестовое решение:
n= 138
138!=691778647261948849222819828311491035886734385827028118707676848307166514238979223884785249055995983385450621636277440066920043595627074569065446040152660143904127838730788278294186615891819670506731208704000000000000000000000000000000000
kalterbrun
в кинозале всего 16×32=512 мест. Сообщение о купленном билете однозначно определяет выбор одного из этих мест. Из уравнения 2 i = 512=29получаем: i=9 бит. Но эту же задачу можно решать иначе. Сообщение о номере ряда несет 4 бита информации, т.к. 24=16. Сообщение о номере места несет 5 бит информации, т.к. 25=32. В целом сообщение про ряд и место несет: 4+5=9 бит информации. Данный пример иллюстрирует выполнение закона активности информации (правило сложения): количество информации в сообщении одновременно о нескольких результатах независимых друг от друга событий равно сумме количеств информации о каждом событии отдельно.

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Написать программу которая вводит с клавиатуры 5 дробных чисел и вычисляет их арифметическое используя цикл for
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

stalker2201
vera141187
svetkaiv
Шиловский126
astahova
Yevgenevich1150
oksanashabanovadc3197
Алексей Шуклин
tokarevmax
yusovd291
Алексеевич949
marinamarinazmeeva2444
msk27
e90969692976
Shurshilina850