ALLA1868
?>

Написать программу через цикл while "найти произведение: p=(1+x) *(3+2x) *(5+ (n множителей заранее )

Информатика

Ответы

Ямпольский
Var
  n: integer;
  x:real;
  p:double;

begin
  Writeln('Введите n и x');
  Read(n);Readln(x);p:=1;
  while (n > 0) do
    begin
      p:= p * (1 + 2*(n-1) + n*x);
      n:= n - 1;
    end;
  Writeln(p);
end.

Пример:
Введите n и x
3 2
231
Yeremeev

165 стр.

Объяснение:

мороженое & ( пирожное | шоколад ) = 427 стр.

мороженое &  пирожное = 262 стр.

мороженое &  пирожное & шоколад = 61 стр.

мороженое & ( пирожное | шоколад ) =

(мороженое & пирожное) | (мороженое & шоколад)

Кол-во стр. (мороженое &  пирожное) | (мороженое & шоколад) минус кол-во стр. мороженое &  пирожное равно кол-во стр. мороженое & шоколад. Значит, кол-во стр. мороженое & шоколад равно 427-262=165 стр.

(На картинке иллюстрация этих множеств)


Мороженое & шоколад? объясните как делать.
Melsan19914239

Маркировка процессоров AMD Athlon 64 настолько сложна и запутанна, что сбивает с толку даже специалистов.

Модельные номера, или рейтинги, были придуманы компанией AMD еще в ту пору, когда она изо всех сил только пыталась конкурировать с Intel. Идея, лежащая в основе псевдочастоты процессора, состоит в том, чтобы объяснить пользователю, аналог какого процессора Intel он покупает. Уже тогда AMD начала пропагандировать тезис о том, что производительность процессора зависит не только от тактовой частоты, но и от других параметров, прежде всего от микроархитектуры и объема встроенной кэш-памяти. Процессорный рейтинг ("псевдо-частота") как раз учитывает разницу по другим параметрам и может быть использован для сравнения процессоров разных производителей. И AMD стала присваивать своим процессорам номера "с плюсом", обозначающие тактовую частоту аналогичных по производительности процессоров Intel.

Отправная точка для процессорного рейтинга действительно была рассчитана на основе результатов тестов. Однако дальше AMD стала присваивать рейтинги просто по возрастающей. А когда появились разные варианты Athlon 64, ситуация с рейтингами окончательно вышла из-под контроля: теперь с рейтинга нужно было отмечать не только разницу в частотах, но и разные кэши, разные процессорные сокеты и т.п. Поэтому в сводной таблице вы найдете много процессоров с одинаковыми номерами, но разными параметрами. Отличить их можно лишь по строке маркировки (OPN), которая нанесена на корпусе процессора непосредственно под его названием.

Когда AMD ввела в строй новую технологию производства, она решила не менять ни название, ни маркировки процессоров. И потому Athlon 64 с разными ревизиями ядра, различающиеся по поддержке разных частот и типов памяти, поддержке набора инструкций, энергопотреблению и потенциалу разгона, можно отличить только по OPN. К счастью, коробки "боксовой" упаковки Athlon 64 имеют прозрачное окошко, через которое маркировку процессора можно легко прочитать. И не купить случайно процессор на старом ядре, который может не поддерживать DDR400 или совсем не разгоняться.

Заметим, что в последнее время AMD начинает исправляться. Среди процессоров на последней модификации ядра Venice уже нет моделей с одинаковыми номерами и разными параметрами. Уже можно говорить об однозначном соответствии номера частоте и объему кэша. Скажем, 3200+ всегда будет иметь частоту 2 ГГц и кэш 512 Кб, а под процессоры с кэшем 1 Мб "зарезервировано" только два номера - 3700+ и 4000+.

Специально для любителей разгона сообщим, что процессоры на ядре Venice (E3, E6), вне зависимости от номера, разгоняются обычно до 2.8-2.9 ГГц. Поэтому имеет смысл покупать самую доступную модель - 3000+, поскольку и она, при должном везении, позволит достичь теоретического предела своего ядра.

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Написать программу через цикл while "найти произведение: p=(1+x) *(3+2x) *(5+ (n множителей заранее )
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

Евгеньевич Балиловна1398
Zhilinoe134
maxkuskov2485
uisfbu7777733
des-32463
Klicheva_Ermachenkova1536
prostopo4ta29
i7aster26
mikchaylovaalex
igraparkGP51
maestro6838
dkvsadovoe
likakedo4ka439
egorsalnikov1997139
kristinagaspa62