Кирьяков-Крикунов
?>

Решить по информатике) нужно написать программу на паскале. тема: циклы вот условие) оргкомитет олимпиады решил организовать обзорную экскурсию для участников олимпиады. для этого был заказан двухэтажный автобус (участников олимпиады достаточно много и в обычный они не умещаются) высотой 437 сантиметров. на экскурсионном маршруте встречаются n мостов. жюри и оргкомитет олимпиады обеспокоены тем, что высокий двухэтажный автобус может не проехать под одним из них. им удалось выяснить точную высоту каждого из мостов. автобус может проехать под мостом тогда и только тогда, когда высота моста превосходит высоту автобуса. организаторам узнать, закончится ли экскурсия благополучно, а если нет, то установить, где произойдет авария. входные данные: во входном файле сначала содержится число n (1< =n< =1000 далее идут n натуральных чисел, не превосходящих 10000 - высоты мостов в сантиметрах в том порядке, в котором они встречаются на пути автобуса. выходные данные: в единственную строку выходного файла нужно вывести фразу "no crash", если экскурсия закончится благополучно. если же произойдет авария, то нужно вывести сообщение "crash k", где k - номер моста, где произойдет авария. фразы выводить без кавычек ровно с одним пробелом внутри.

Информатика

Ответы

margo929
Var
tmp,n,i:integer;
begin
Readln(n);
for i:= 1 to n do begin
readln(tmp);
if tmp <= 437 then
begin
  Writeln('Crash ', i);
  halt;
end;
end;
Writeln('No Crash');
end.
larazaytseva
Вообщем стратегия такая: сначала наращиваем мощности, а потом копим печеньки
Программа вычисляет оптимальную максимальную мощность. Это оказывается 9 или 10 печенек в день (т.е 8 или 9 духовок)
в минимуме в общем целом на это уйдет 108 дней

код на руби

(1..100).step(1) {|max_productivity|
    productivity = 1
    cockies = 0
    days = 0
    upgrade_cost = 5 * productivity

    while cockies < 532
        if cockies >= upgrade_cost and productivity < max_productivity
            cockies -= upgrade_cost
            productivity += 1
            upgrade_cost = 5 * productivity
        else
            cockies += productivity
        end

        days += 1
    end
    p [max_productivity, days, cockies, productivity]
}

Вывод (куска)
[6, 119, 534, 6]
[7, 112, 532, 7]
[8, 109, 536, 8]
[9, 108, 540, 9]
[10, 108, 540, 10]
[11, 109, 539, 11]
[12, 111, 540, 12]
[13, 113, 533, 13]
[14, 116, 532, 14]
[15, 120, 540, 15]
[16, 124, 544, 16]
[17, 128, 544, 17]
[18, 132, 540, 18]
boro-1973
Я уже решал эту задачу.
Я руками за 5 дней делаю 5 коробок, и на 6-ой день покупаю духовку.
Руками и духовкой я делаю 2 коробки в день, за 5 дней - 10 коробок.
На 6-ой день я покупаю вторую духовку.
Руками и 2-мя духовками я за 5 дней делаю 15 коробок, и на 6-ой день покупаю 3-ью духовку.
И так далее. Чтобы купить очередную духовку, я работаю 5 дней, а на 6-ой день ее покупаю, и у меня печенья не остается совсем.
То есть, после покупки каждой духовки я начинаю всё с нуля.
Главное - понять, когда нужно остановиться покупать духовки и начать уже копить печенье на складе.
Итак, подведем итоги:
1) На покупку каждой духовки мы тратим 6 суток и начинаем с нуля.
2) Имея n духовок, мы делаем 584 коробок печенья за 
trunc(584/(n+1)) + 1 дней, где trunc(x) = [x] - это целая часть x. 
3) Всего мы тратим времени T(n) = 6n + trunc(584/(n+1)) + 1 --> min
Минимум функции trunc(584/(n+1)) совпадает с минимумом 584/(n+1)
T(n) = 6n + 584/(n+1) + 1 --> min
T'(n) = 6 - 584/(n+1)^2 = (6(n+1)^2 - 584) / (n+1)^2 = 0
6(n+1)^2 - 584 = 0
(n+1)^2 = 584/6 = 97,33
n + 1 = √97,33 ~ 9,86 = 10
n = 9
Значит, нужно ограничиться покупкой 9 духовок.
За 6*9 = 54 дня мы их купим, и за 584/10 ~ 59 дней мы соберем нужное количество коробок на складе.
Всего мы истратим 54 + 59 = 113 дней.

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Решить по информатике) нужно написать программу на паскале. тема: циклы вот условие) оргкомитет олимпиады решил организовать обзорную экскурсию для участников олимпиады. для этого был заказан двухэтажный автобус (участников олимпиады достаточно много и в обычный они не умещаются) высотой 437 сантиметров. на экскурсионном маршруте встречаются n мостов. жюри и оргкомитет олимпиады обеспокоены тем, что высокий двухэтажный автобус может не проехать под одним из них. им удалось выяснить точную высоту каждого из мостов. автобус может проехать под мостом тогда и только тогда, когда высота моста превосходит высоту автобуса. организаторам узнать, закончится ли экскурсия благополучно, а если нет, то установить, где произойдет авария. входные данные: во входном файле сначала содержится число n (1< =n< =1000 далее идут n натуральных чисел, не превосходящих 10000 - высоты мостов в сантиметрах в том порядке, в котором они встречаются на пути автобуса. выходные данные: в единственную строку выходного файла нужно вывести фразу "no crash", если экскурсия закончится благополучно. если же произойдет авария, то нужно вывести сообщение "crash k", где k - номер моста, где произойдет авария. фразы выводить без кавычек ровно с одним пробелом внутри.
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

manager9
ГазалиеваКозак
ПодлеснаяМакарова1883
Alekseevich_Viktorovna
st7307
Александра Викторович531
Переведите в килобайты : а) 10240 бит, б) 20 мбайт
ЛаринаЛощаков
Анна Марина1873
Вера1072
armusaeff
kisuhakisa
Pavlushina-Novikova
mail5
agaltsova86
lor005148
▲