Умаляю число жителей города - k тыс. человек. ежегодно население в нем увеличивается на 2%. составьте программу вычисления количества жителей города через год. значение переменной k ввести с клавиатуры.
Число делить на 100 и умножать на 102 каждый раз. Что сложного?
Код на C#, мало чем отличается: int K = Convert.ToInt32(textbox1.Text); // заменяешь функцией чтения введённого значения int otvet = K/100*102; // твой ответ
kmr495270
08.12.2022
Сначала надо избавиться от ошибок (пункт №3) иначе не сможем выполнить 1 и 2 пункт задания. Исправляем if N mod 10 k:=N mod 10; на if (N mod 10 < k) then k:=N mod 10; Исправляем N:N div 10; на N:= N div 10;
После исправления ошибок при вводе 537 получим 3 Программа будет работать правильно для любого числа, у которого вторая цифра слева меньше первой цифры, например: 7193
Чтобы программа работала правильно для всех чисел надо изменить это: while N > 10 do на while N > 0 do
После всех исправлений код программы стал таким: var N, k: integer; begin readln(N); k := 9; while N > 10 do begin if (N mod 10 < k) then k := N mod 10; N := N div 10; end; write(k) end.
Espivak
08.12.2022
А вот так понятнее: 1001110= 1) проставь над каждой цифрой числа справо на лево двойки со степенями т.о. чтобы над первым нулем (справа) стояла 2 в нулевой степени, над единицей - 2 в первой степени, над следующей единицей - 2 во второй степени, и т.д. Т.О над последней единицей (слево) будет 2 в седьмой степени. а теперь смотри как получается число в десятичной: надо сложить произведения этиз двоек на те числа, которые стоят под ними соответственно. итак: 1001110=2в шестой* 1+2в пятой*0+2 в четвертой*0+2 в третьей*1+2 во второй*1+2 впервой*1+2 в нулевой*0 = 64+8+4+2=78
Код на C#, мало чем отличается:
int K = Convert.ToInt32(textbox1.Text); // заменяешь функцией чтения введённого значения
int otvet = K/100*102; // твой ответ