eeirikh
?>

1. написать программу, которая подсчитывает количество, сумму и среднее арифметическое положительных чисел последовательности. размер последовательности определяет сам пользователь программы. 2. написать программу, которая подсчитывает сумму и количество чисел последовательности, делящихся на 8 без остатка. размер последовательности определяет сам пользователь программы. принять, что последовательность состоит только из целых положительных чисел.

Информатика

Ответы

svetasvetlana429
Varsumma,Shet,a,b,c:integer;SAP:real;L:array [1..999] of integer;beginWrite('Сколько чисел? ');read(a);for b:=1 to a do beginwrite('Введите число ' );read(c);if (c>0) then begin Shet:=Shet+1; summa:=summa+c; SAP:=SAP+c; end;end;SAP:=SAP/Shet;Writeln(' Сумма = ',summa,' Сред = ',SAP:5:5,' Количество = ',Shet);read(a);end.
girra

      саксофон     пиан      ударн                    географ.фак     ист.фак   физ.фак.  биолог

М          +                 -              -                                     -                     -                                      

В           -                +              -                                      +                    -                -                  -

А           -                  -             -                                     -                    +                 -                 -            

Л           -                 -             +                                      -                   -                                         

 

Валерий пианист - географич. фак 

Александровна-Павловна
Код

var
    x, y, z, a, b, c, d, t: integer ;

begin
    x := 336;
    y := 8;
    x := x div y;
    y := x mod y;
    writeln('x = ', x, ', y = ', y);
   
    a := 1686;
    b := (a div 10) mod 5;
    a := a - 200 * b;
    writeln('a = ', a, ', b = ', b);
   
    x := 11;
    y := 5;
    t := y;
    y := x mod y;
    x := t;
    y := y + 2 * t;
    writeln('x = ', x, ', y = ', y, ', t = ', t);
   
    x := 19;
    y := 3;
    z := y * 2;
    y := x mod y;
    x := x - z;
    y := y + z;
    writeln('x = ', x, ', y = ', y, ', z = ', z);
   
    x := 13;
    y := 3;
    z := x;
    x := z div y;
    y := x;
    writeln('x = ', x, ', y = ', y, ', z = ', z);
end.

Вывод и ответы по очереди

1) x = 42, y = 2
2) a = 1086, b = 3
3) x = 5, y = 11, t = 5
4) x = 13, y = 7, z = 6
5) x = 4, y = 4, z = 13

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

1. написать программу, которая подсчитывает количество, сумму и среднее арифметическое положительных чисел последовательности. размер последовательности определяет сам пользователь программы. 2. написать программу, которая подсчитывает сумму и количество чисел последовательности, делящихся на 8 без остатка. размер последовательности определяет сам пользователь программы. принять, что последовательность состоит только из целых положительных чисел.
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

titancore
utburt
Olga Arutyunyan
denbelousov963
Morozova-Starikov
tarhan1221
Александр Елена1290
Vyacheslavovna240
antilopa001
Lomakina-Valerievna1779
ibarskova1542
samuilik-v
Zolotnik974620
konss2
Sergei