Напишите программу на с++, которая вводит последовательность целых чисел, заканчивающихся нулем, и определяет количество четных положительных чисел в этой последовательности
#include <iostream> #include <iomanip> using namespace std;
int main() { int n,k=0; for (int i=0; ;) { cin>>n; if (n==0) break; if (n%2==0 && n>0) k++; } cout<<k<<endl; system("pause"); return 0; }
3 -15 -18 14 7 9 -12 10 0 2
irinakiral
02.01.2022
Python 3.5: a, b, c, d = list(map(float, input().split())) print(False if (c == d) else ((a + b + c + d)/(c - d)).is_integer())
Сначала вводим 4 вещественных числа a, b, c, d. Если c = d, то ответ False - частное будет нехорошим, поскольку в знаменателе будет 0. Если c не равно d, проверяем при встроенной функции is_integer(), что (a + b + c + d)/(c - d) - целое число.
Если a, b, c, d - целые, то float в решении можно заменить на int, а проверку при на проверку, что остаток от деления равен нулю, (a + b + c + d) % (c - d) == 0.
БеляковаСтаниславовна
02.01.2022
// PascalABC.NET 3.2, сборка 1382 от 06.02.2017 // Внимание! Если программа не работает, обновите версию!
begin var a:=ArrRandom(ReadInteger('n='),-99,99); a.Println; var b:=ArrRandom(ReadInteger('n='),-99,99); b.Println; (var ma,var mb):=(a.Average,b.Average); // средние арифметические var s:=ma+mb; // их сумма Writeln('Среднее арифметическое массива а: ',ma); Writeln('Среднее арифметическое массива b: ',mb); Writeln('Их сумма: ',s) end.
Напишите программу на с++, которая вводит последовательность целых чисел, заканчивающихся нулем, и определяет количество четных положительных чисел в этой последовательности
#include <iomanip>
using namespace std;
int main() {
int n,k=0;
for (int i=0; ;) {
cin>>n;
if (n==0) break;
if (n%2==0 && n>0) k++;
}
cout<<k<<endl;
system("pause");
return 0;
}
3 -15 -18 14 7 9 -12 10 0
2