Алина1564
?>

Напишите программу выводящую на экран последовательность чисел от 1 до n. число n вводиться с клавиатуры. решать с++ .

Информатика

Ответы

Alekseeva_Khlistov
Решение смотри во вложении.
Напишите программу выводящую на экран последовательность чисел от 1 до n. число n вводиться с клавиа
ustinovda14
Const
  n = 9;
var
  a:array[1..n,1..n] of integer;
  i,j,k,max: integer;

begin
  Randomize;
  Writeln('Исходная матрица');
  max:=-100;
  for i:=1 to n do
  begin
    for j:=1 to n do
    begin
      a[i,j]:=Random(51)-25;
      Write(a[i,j]:4);
      if max<a[i,j] then max:=a[i,j]
    end;
    Writeln
  end;
 
  for i:=2 to n-1 do { не просматривать первую и последнюю строки }
    for j:=1 to n do
      if a[i,j]=max then a[i,j]:=0;
 
  Writeln('Результирующая матрица');
  for i:=1 to n do
  begin
    for j:=1 to n do Write(a[i,j]:4);
    Writeln
  end;
end.

Тестовое решение:
Исходная матрица
 -19 -24 -24 -21   0 -12 -16  12   7
  19  -2  22  12  -7 -19  25 -20 -21
  18   4  -6   9   7  -9  21   1   5
  25 -17  10  22  -7 -18  10  -6  -3
  24  -2   2 -22 -11 -13   5  24  11
   1  -7  16  24   4 -19  -6   7  21
  -9  -3  -5  10 -16  25   9 -15   4
  23  22 -20  14 -23  24   9 -24   8
   2  14 -10 -19 -21   8   6  -6 -17
Результирующая матрица
 -19 -24 -24 -21   0 -12 -16  12   7
  19  -2  22  12  -7 -19   0 -20 -21
  18   4  -6   9   7  -9  21   1   5
   0 -17  10  22  -7 -18  10  -6  -3
  24  -2   2 -22 -11 -13   5  24  11
   1  -7  16  24   4 -19  -6   7  21
  -9  -3  -5  10 -16   0   9 -15   4
  23  22 -20  14 -23  24   9 -24   8
   2  14 -10 -19 -21   8   6  -6 -17
usmanovayanq2626
Частота дискретизации D = 44000 гц
разрядность i = 16 бит
t = 1 мин = 60 сек.
Стереозапись включает в себя 2 дорожки,а значит объем информации увеличивается вдвое, поэтому добавим в конечную формулу коэффициент 2.
Объем информации L =2*D*i*t = 44000*16*60*2=84480000 бит=10560000 байт=10Мбайт.

ответ: одна минута стереозаписи занимает 10Мбайт.

L = 700Мбайт = 734003200 байт
D = 44000 гц
i=16 бит = 2 байта
(тип звукозаписи - стерео => добавляется коэффициент 2)
t=L/(D*i*2)
t = 734003200/(2*44000*2) = 4170,47 сек = 69,5 мин.

ответ: 69,5 минут максимальная продолжительность стереозаписи на диске 700 Мбайт 

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Напишите программу выводящую на экран последовательность чисел от 1 до n. число n вводиться с клавиатуры. решать с++ .
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

targovich
eurostom
Vipnikavto58
Aleksey19801
Наталья Юрьевич1228
edvard-b
annarom1306
helenavalenti2846
taksa6444
Drugov_Vladimirovna
mariia39
guujuu
ikhilovb76
Valerii276
Газинурович
▲