nikitavertiev98400
?>

По теме циклы 1. написать программу на языке паскаль, выводящую все отрицательные члены арифметической прогрессии -11; -7… 2. написать программу на языке паскаль, находящую сумму первых десяти натуральных чисел. 3. написать программу на языке паскаль, находящую сумму положительных членов арифметической прогрессии: 17; 11; … help pls my lovely friend

Информатика

Ответы

ss2911
2.
Program num;uses crt;var x,y,i,l:integer;begintextcolor(11);writeln('Введите i: ');readln(i);y:=0;for x:=14 to i do  //Вместо 14 можешь вписать любое натуральное число но не больше "i"beginy:=y+x;end;write ('ответ', y);readln;end.
1 и 3 можешь посмотреть у меня в профиле.
Григорьевич915
#include <stdlib.h>
#include <iostream>
#include <iomanip>
using namespace std;

int main() {
const int n = 5;
double a[n][n];
double m1, m2;

srand(time(0));
for (int i = 0; i < n; i++){
 for (int j = 0; j < n; j++){
a[i][j]=-20 + (101.0 / RAND_MAX) * rand();
cout << fixed << setw (7) << setprecision (2) << a[i][j];
 }
cout <<endl;
}
m1=a[0][0];
m2=a[0][n-1];
for (int i = 1; i < n; i++){
 if (a[i][i]>m1) m1=a[i][i];
 if (a[i][n-i-1]>m2) m2=a[i][n-i-1];
 }
 cout << "m1=" << m1 << "  m2=" << m2 << endl;
}
  37.11  71.19  25.77  53.53  35.74
  39.90  63.69  11.67  70.38  -4.10
  64.46  52.37  35.03  42.58  69.18
  44.22   8.46  13.23  71.17   3.10
   6.83  65.07  75.24  21.61  37.22
m1=71.17  m2=70.38
mursvita943
Задание №1 

var s,v,t,a:real; 
begin 
writeln('Введите скорость, ускорение и время соотвественно'); 
read(v,a,t); 
s:=v*t+(a*sqr(t))/2; 
writeln('Расстояние S = ',s); 
end.

Задание №2

var a,b,c,d,m,n:integer; 
begin 
writeln('Введите ширину и высоту комнаты'); 
read(a,b); 
writeln('Введите размеры окна'); 
read(c,d); 
writeln('Введите размеры двери'); 
read(m,n); 
writeln('Площадь стен для оклеивания обоями = ',a*b-c*d-m*n); 
end.

Задание №3

var a,b:real; 
begin 
writeln('Введите два числа'); 
read(a,b); 
writeln('Среднее арифметическое кубов этих чисел = ',(power(a,3)+power(b,3))/2); 
writeln('Среднее геометрическое модулей этих чисел = ',sqrt(abs(a*b))); 
end.

Задание №4

var x:real; 
begin 
writeln('Введите ребро куба'); 
read(x); 
writeln('Площадь грани = ',sqr(x)); 
writeln('Площадь полной поверхности = ',6*sqr(x)); 
writeln('Объем куба = ',power(x,3)); 
end.

Задание №5

var r1,r2:real; 
begin 
writeln('Введите внешний и внутренний радиус'); 
read(r1,r2); 
if r1<r2 then writeln('Внешний радиус должен быть больше внутреннего') else 
writeln('Площадь кольца = ', Pi*sqr(r1)-Pi*sqr(r2)); 
end.

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

По теме циклы 1. написать программу на языке паскаль, выводящую все отрицательные члены арифметической прогрессии -11; -7… 2. написать программу на языке паскаль, находящую сумму первых десяти натуральных чисел. 3. написать программу на языке паскаль, находящую сумму положительных членов арифметической прогрессии: 17; 11; … help pls my lovely friend
Ваше имя (никнейм)*
Email*
Комментарий*