Воздвиженская
?>

Язык с# 1.1 написать программу вычисления стоимости покупки с учетом скидки. если сумма покупки меньше 1000 руб., то стоимость покупки не изменяется, а если больше, то предоставляется скидка в 10%. 1.2 получить таблицу пересчета миль в километры (1 миля = 1, 609344 км) для расстояний, не превышающих k км.

Информатика

Ответы

avakarica
     //Задача 1            Console.WriteLine("Введите количество товара");            string r = Console.ReadLine();            double n = Convert.ToDouble(r1) ;            double tovar = 250;            double sum = 0.0;            double skidka = 0.1;            double oplata;                      sum = tovar * n;            if (sum <= 1000){                oplata = sum;            }            else            {                oplata = sum - sum * skidka;            }
            Console .WriteLine("Колис товара=" + n + " Цена товара = " + tovar + " стоимость покупки= "+ sum +  " Оплата = " + oplata );            //Задача2            Console.WriteLine("Введите количество к км");            string r1 = Console.ReadLine();            double k = Convert.ToDouble(r1);            double q = 1.609344;            for (int i = 1; i < k + 1; i++)            {                Console.Write("км = " + i + " "); Console.WriteLine("миля = " + i / q);            }             Console.ReadKey();
adminaa
import java.util.*;
import java.lang.*;

class {
public static void main(String[] args){

Scanner sc = new Scanner(System.in); // то для ввода

System.out.print("Enter ch: ");
int ch = sc.nextInt();

int size = 0;
int toWil = 1;
int i = 1;

while(toWil == 1){
ch /= (10 * i);
if(ch == 0){
toWil = 0;
}
else{
size++;
};
};

int arr[] = new int[size];
i = 1;

while(toWil == 0){
ch /= (10 * i);
if(ch == 0){
toWil = 1;
}
else{
arr[i - 1] = ch;
};
};

i = 0;

while(toWil == 1){
arr[i] += 4;
if(arr[i] >= 10){
if(i == (size - 1)) {

}
else{
arr[i + 1] += 1;
};
};


};

for(i = size; i >= 1; i++){
System.out.print(arr[i]);
}

}
}
moskwa999
import java.util.*;
import java.lang.*;

class {
public static void main(String[] args){

Scanner sc = new Scanner(System.in);
int a, b, c;

System.out.print("Enter a: "); a = sc.nextInt();
System.out.print("Enter b: "); b = sc.nextInt();
System.out.print("Enter c: "); c = sc.nextInt();

int pol[] = new int[3];
pol[0] = a;
pol[1] = b;
pol[2] = c;

for(int i = 0; i < 3; i++){
if(pol[i] < 0){
pol[i] = 0;
};
};

for(int i = 1; i < 3; i++){
pol[0] += pol[i];
};

System.out.print("sum: " + pol[0]);
}
}

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Язык с# 1.1 написать программу вычисления стоимости покупки с учетом скидки. если сумма покупки меньше 1000 руб., то стоимость покупки не изменяется, а если больше, то предоставляется скидка в 10%. 1.2 получить таблицу пересчета миль в километры (1 миля = 1, 609344 км) для расстояний, не превышающих k км.
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

buff-studio
fiorire731
Илья Владимировна
Kalashnikova
fursov-da
Gennadevna_Baidalina131
Виктор Попова
snopovajulia
ocik1632933
kruttorg
Olga Arutyunyan
s-shulga
podenkovaev314
blackpoint2020273
fetisov68av