samofar
?>

Решить на python часть списка в конец имеется список из n элементов (n < 101 измените исходный список, переставив s элементов списка в конец, начиная с элемента под номером p. формат входных данных в первой строке вводится n (n < 101) - размерность списка. во второй строке через пробел вводятся n элементов списка в третьей строке вводятся числа s (количество переставляемых элементов) и p (номер первого из s элементов). формат выходных данных вывести измененный список. примеры входные данные 10 98 37 59 93 60 94 14 19 -38 -76 5 3 выходные данные 98 37 19 -38 -76 59 93 60 94 14

Информатика

Ответы

katar050419735
n = int(input('Введите кол-во чисел: '))
a = []
for k in range(n):
 m = int(input('Введите число:'))
 a.append(m)
s = int(input('Введите кол-во заменяемых элементов: '))
for j in range(s):
 s1 = int(input('Внимание: [0] это индекс первого элемента. Введите индекс заменяемого элемента: '))
 a.append(a[s1])
 a.remove([s1])
print(a)
luza5

#include <iostream>

using namespace std;

int main(int argc, char** argv)

{

int a,b,s,p;

cout<<"Input a: ";

cin>>a;

cout<<"Input b: ";

cin>>b;

p = (a+b)*2;  

s= a*b;

cout<<"Perimetr: "<<p<<"\nPloschad: "<<s<<endl;

}

Диагональ не знаю как.

2. #include <iostream>

using namespace std;

int main(int argc, char** argv)

{

int a,b,c;

cout<<"Input a: ";

cin>>a;

cout<<"Input b: ";

cin>>b;

cout<<"Input c: ";

cin>>c;

if(a==b or a==c)

{

 cout<<"Yes!"<<endl;

}

else if(b==a or b==c)

{

 cout<<"Yes!"<<endl;

}

else if(c==a or c==b)

{

 cout<<"Yes!"<<endl;

}

else

{

 cout<<"Oops!"<<endl;

}

}

3. #include <iostream>

using namespace std;

int main(int argc, char** argv)

{

setlocale(LC_ALL, "Russian");

int a;

cout<<"Input a: ";

cin>>a;

switch(a)

{

 case 1:

 case 2:

 case 3:

  cout<<"Íèçêèé!"<<endl;

  break;

 case 4:

 case 5:

 case 6:

  cout<<"Ñðåäíèé!"<<endl;

  break;

 case 7:

 case 8:

 case 9:

  cout<<"Äîñòàòî÷íûé!"<<endl;

  break;

 case 10:

 case 11:

 case 12:

  cout<<"Âûñîêèé!"<<endl;

  break;

 default:

  cout<<"Error!"<<endl;

  break;

}

}

4. #include <iostream>

using namespace std;

int main(int argc, char** argv)

{

int a, a1, a2, a3, a4, a5, a6;

cout<<"Input a: ";

cin>>a;

a1=a/1000;

a2=a/100%10;

a3=a%100/10;

a4=a%10;

a5=a1;

a6=a3;

if(a5>a1 && a6>a3)

{

 cout<<"Number more"<<endl;

}

}

Вроде так

Объяснение:

Artyukhin545

Free Pascal.  Все три задания в одном коде.

Объяснение:

const k=10;

var

 a, i, n: integer;

 s : double;

 ar : array[0..k-1] of integer;

begin

 writeln('Задание 4');

 write('Введите число : ');

 readln(a);

 for i:=8 to 18 do

   if a>=0 then

     write(sqrt(i):2:2, '  ')

   else

     writeln((i+0.8):2:1);

 writeln();

 writeln('---------------------------------');

 writeln('Задание 5');

 write('Введите n : ');

 readln(n);

  s:=0;

  for i:= 1 to n do

    s := s + i/2;

  writeln('Сумма ряда = ', s:2:1);

  if s>10 then

    writeln('Сумма ряда больше 10')

  else

    writeln('Сумма ряда меньше 10');

 writeln('---------------------------------');

 writeln('Задание 6');

 for i:=0 to k-1 do begin

   write('введите [', i, '] = ');

   readln(ar[i]);

 end;

 n:=0;

 for i:=0 to k-1 do

   if (ar[i] mod 2 = 0) then

     inc(n);

 writeln('Кол-во чётных чисел = ', n);

end.


Решите задачи в паскале

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Решить на python часть списка в конец имеется список из n элементов (n < 101 измените исходный список, переставив s элементов списка в конец, начиная с элемента под номером p. формат входных данных в первой строке вводится n (n < 101) - размерность списка. во второй строке через пробел вводятся n элементов списка в третьей строке вводятся числа s (количество переставляемых элементов) и p (номер первого из s элементов). формат выходных данных вывести измененный список. примеры входные данные 10 98 37 59 93 60 94 14 19 -38 -76 5 3 выходные данные 98 37 19 -38 -76 59 93 60 94 14
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

dimon198808744
khvorykhphoto
makashi28
mdsazonovatv1173
departed744
spikahome
Bolshakova Shigorina
alina-bas
shtankosoyuz1629
nestruev
yastrik
luksorsps20096124
tanysha1990
optikaleks7
solonataly5
▲