uses crt; var a: array [1..20, 1..20] of real; i, j, k, n, s: integer; begin clrscr; write('Введите размер матрицы: '); read(n); for i := 1 to n do for j := 1 to n do begin write('A[', i, ',', j, ']= '); readln(a[i, j]); end; WRITELN; WRITELN; writeln('Исходная матрица ', n, 'x', n, ': '); for i := 1 to n do begin for j := 1 to n do WRITE(a[i, j]:2:0, ' '); WRITELN; end; k := 0; for i := 1 to n do begin for j := 1 to n do begin if a[i, j] = 0 then begin k := k + 1; s := s + 1; end; end; if k = n then writeln(i, ' строка состоит из нулей! '); k := 0; end; if s = 0 then writeln('В матрице нет нулевых строк'); end.
Поделитесь своими знаниями, ответьте на вопрос:
Напишите программу, которая получает с клавиатуры целое число и записывает в логическую переменную значение «да» (true), если это число трёхзначное. после этого на экран выводится ответ на вопрос: «верно ли, что было получено трёхзначное число? »
var
i: Integer;
b:Boolean;
begin
Write('Введите число: ');
ReadLn(i);
if ((i<-99) and (i>-1000)) or ((i>99) and (i<1000))
then b:=true;
WriteLn(b);
end.