snezhanaklimenkova
?>

Написать программу, которая вычисляет сумму первых n натуральных чисел составьте программу с while)

Информатика

Ответы

AMR89154331531
Program n1;
var n,sum,i: integer;
begin
readln(n);
i:=1;
while i<=n do
begin
sum:=sum+i;
i:=i+1;
end;
write(sum);
end.
lukur2005
PascalABC.NET 3.4.2, сборка 1843 от 24.10.2018Внимание! Если программа не работает, обновите версию!

begin

 var n := ReadInteger('Размер массива:');

 var k := ReadInteger('Максимальное значение элемента:');

 var a := ArrRandom(n, 0, k);

 a.Println;

 var b := ArrRandom(n, 0, k);

 b.Println;

 var c := a.Zip(b, (p, q)-> p + q).ToArray;

 c.Println;

 k := c.Max;

 var v := ArrFill(k + 1, 0);

 for var i := 0 to c.High do

   v[c[i]] += 1;

 var d := 0;

 for var j := 0 to k do

   for var i := 0 to v[j] - 1 do

   begin

     c[d] := j;

     d += 1

   end;

 c.Println

end.

Размер массива: 15Максимальное значение элемента: 4031 11 31 28 10 30 16 38 24 25 11 38 0 29 3531 36 6 35 15 2 13 34 10 6 37 14 32 31 1062 47 37 63 25 32 29 72 34 31 48 52 32 60 4525 29 31 32 32 34 37 45 47 48 52 60 62 63 72
abuzik
PascalABC.NET 3.4.2, сборка 1843 от 24.10.2018Внимание! Если программа не работает, обновите версию!

begin

 var n := ReadInteger('n=');

 var a := ArrRandom(n, -99, 99);

 a.Println;

 var b := SeqRandom(n, -10, 10).Select(t -> t = 0 ? 1 : t).ToArray;

 b.Println;

 var c := a.Zip(b, (p, q)-> p div q).ToArray;

 c.Println;

 Print('Нечетных элементов:');

 a.Where(t -> t.IsOdd).Count.Print;

 b.Where(t -> t.IsOdd).Count.Print;

 c.Where(t -> t.IsOdd).Count.Println;

end.

n= 1372 94 79 3 15 -82 72 -72 14 -79 23 -48 26-6 9 3 10 -2 10 -3 -7 5 -4 -6 7 -1-12 10 26 0 -7 -8 -24 10 2 19 -3 -6 -26Нечетных элементов: 5 7 3

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Написать программу, которая вычисляет сумму первых n натуральных чисел составьте программу с while)
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

tkmandarin8376
petr2077
dream2366
westgti77105
info32
Koranna1986
mstrshulz
ogonizoloto
ВайсманКреденс357
elenachuxina804
gurman171
lsyrbu
РобертИрина
IAleksandrovna45
Alekseevna1064