buyamel
?>

Яне могу скачать майкрософт ворд (любого года), сколько не пытаюсь скачиваются левые программы, киньте прямую ссылку на скачивание ( windows 7)

Информатика

Ответы

igortychinin
Зайди там все есть
elena-ppk
1.
var
  s: string;
  i, count: integer;
begin
  writeln('Vvedite stroky: ');
  readln(s);
  for i := 1 to length(s) - 2 do
    if copy(s, i, 3) = 'abc' then
      count := count + 1;
  writeln('Kol-vo: ', count);
end.
2.
var
  s1, s2: string;
  i, len1, len2: integer;
begin
  writeln('Vvedite stroky 1: ');
  readln(s1);
  writeln('Vvedite stroky 2: ');
  readln(s2);
  len1 := length(s1);
  len2 := length(s2);
  if len1 > len2 then writeln('1 stroka dlinnee')
  else if len1 < len2 then writeln('2 stroka dlinnee')
  else writeln('dlini strok ravnie')
end.
3.
var
  s1, s2, s3: string;
begin
  writeln('Vvedite stroky 1: ');
  readln(s1);
  writeln('Vvedite stroky 2: ');
  readln(s2);
  s3 := s1[1] + s1[2] + s2[1] + s2[2];
  writeln('Novaja stroka: ', s3);
end.
Savelieva24

6251413

Объяснение:

Поскольку функция рекурсивно вызывает себя и при каждом вызове выводит переданное число, удобно будет записать выводимые числа в столбик, обозначая глубину стека (количество рекурсивных вызовов) и произойдет ли вызов. Очередная пара рекуррентных вызовов происходит при передаче числа больше или равного четырём.

0: F(6) -> 6 (вызов произойдёт)

1: F(2) -> 2 (вызов не произойдёт)

1: F(5) -> 5 (вызов произойдёт)

2: F(1) -> 1 (вызов произойдёт)

2: F(4) -> 4 (вызов произойдёт)

3: F(1) -> 1 (вызов не произойдёт)

3: F(3) -> 3 (вызов не произойдёт)

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Яне могу скачать майкрософт ворд (любого года), сколько не пытаюсь скачиваются левые программы, киньте прямую ссылку на скачивание ( windows 7)
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

Verdievruslan
thebest59
polyakovaelena
tochkamail7
Ольга Сергей1822
Написать программу для кумира
simplexsol
tanyatanyat
ntinyakova
Doronin755
ivanrancev
boro-1973
oalexandrova75
dubaiexport
KononovaMaiorov453
nkaminskaja