Azat859
?>

35 ! ниже записана программа. получив на вход число , эта программа печатает два числа, и . укажите максимальное и минимальное числа, при вводе которых алгоритм печатает сначала 3, а потом 7.цел x, l, mввод xl: =0; m: =0нц пока x > 0 l: = l + 1 если mod(x, 2) = 1 то m: = m + div(mod(x, 10), 2) все x: = div(x, 10)кцвывод l, нсвывод m, нсvar x, l, m: integer; begin readln(x); l: =0; m: =0; while x > 0 do begin l: = l + 1; if x mod 2 = 1 then m: = m + (x mod 10) div 2; x: = x div 10; end; writeln(l); write(m); end.​

Информатика

Ответы

Руслан Руденко1262
// PascalABC.NET 3.1, сборка 1230 от 27.04.2016
begin
  var n:=ReadInteger('n=');
  var a:=MatrixRandom(n,n,10,99);
  var s:=0;
  var k:=0;
  for var i:=0 to n-1 do begin
    for var j:=0 to n-1 do Print(a[i,j]);
    Writeln;
    if a[i,i].IsEven then begin s+=a[i,i]; Inc(k) end;
    end;
  if k>0 then Writeln('S=',s/k:0:2)
  else Writeln('На главной диагонали нет четных элементов')
end.

Тестовое решение
n= 8
63 13 33 90 25 21 87 91
88 88 48 13 30 59 81 27
73 23 76 77 52 19 33 97
53 87 13 74 17 35 61 70
77 96 51 61 82 33 63 22
39 88 84 54 88 73 74 69
76 26 69 14 45 80 70 54
80 36 47 38 18 22 84 62
S=75.33
vgolentsova

bool ok1(int a, int b, int c){

  return (a+b > c && a+c > b && b+c > a) && min(a,min(b,c)) > 0;

}

bool ok2(int a, int b, int c){

  return ok1(a,b,c) && (a == b || a == c || b == c);

}

signed main(){

  const int n = 3, m = 7;

  int arr[n][m];

  for(int i = 0; i < n; i++)

      for(int j = 0; j < m; j++)

          cin >> arr[i][j];

  vector<int> ans;

  for(int j = 0; j < m; j++)

      if(ok2(arr[0][j],arr[1][j],arr[2][j]))

          ans.push_back(j+1);

  cout << ans.size() << "\n";

  for(auto i: ans)

      cout << i << " ";

}

Подробнее - на -

Объяснение:

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

35 ! ниже записана программа. получив на вход число , эта программа печатает два числа, и . укажите максимальное и минимальное числа, при вводе которых алгоритм печатает сначала 3, а потом 7.цел x, l, mввод xl: =0; m: =0нц пока x > 0 l: = l + 1 если mod(x, 2) = 1 то m: = m + div(mod(x, 10), 2) все x: = div(x, 10)кцвывод l, нсвывод m, нсvar x, l, m: integer; begin readln(x); l: =0; m: =0; while x > 0 do begin l: = l + 1; if x mod 2 = 1 then m: = m + (x mod 10) div 2; x: = x div 10; end; writeln(l); write(m); end.​
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

галина
bruise6
kgrechin
dmdlir
espectr-m
Belik-elena20111
Yelena Kotova
koldunovan
avanesss
ocik1632933
lanabogd
aerendzhenova5
Vladimir1172
starabanov
Vasilisan