Anatolevich_Kulikov1229
?>

Дружественные числа – это два натуральных числа, таких, что сумма всех делителей одного числа (меньших самого этого числа) равна другому числу, и наоборот. напишите программу, которая будет искать дружеские пары чисел до 100 000. pascal

Информатика

Ответы

bagrjashv41
Function sum_del(x: longint): longint;
var
    s, i: longint;
begin
    s := 0;
    for i := 1 to x div 2 do
        if x mod i = 0 then
            s := s + i;
    sum_del := s;
end;

var
    i, s1, s2: longint;
begin
    for i := 1 to 100000 do
    begin
        s1 := sum_del(i);
        s2 := sum_del(s1);
        if (s2 = i) and (s1 < i) then
            writeln(s1, ' ', i);
    end;
end.
devochkadafka624

В оглавлении произведения, разбитого на части, разделы, подразделы, главы, подглавы, параграфы, подпараграфы, примечания и т. п., устанавливающие соподчиненность отдельных частей произведения, последовательно приводятся наименования частей, разделов, глав, параграфов в полном объёме, так, как они даны в тексте, и указываются страницы, на которых начинается рубрика. Рубрики последней ступени — подзаголовки, взятые в тексте рукописи в подбор, — в оглавлении могут не приводиться. Взаимоподчиненность частей произведения в оглавлении передают средствами полиграфического оформления: выделением в красную строку, шрифт

ietishkin

1. Чтобы решить задачу, надо определить, какое количество варенья съест Машенька за 20 дней. Вначале вычислим это количество в ложках, если известно, что за день она съедает по 5 ложек варенья:

5 * 20 = 100 ложек.

2. Теперь переведем 100 ложек варенья в граммы, если известно, что каждая ложка помещает 5 г варенья:

100 * 5 = 500 грамм.

3. Если исходное количество варенья составляет 650 грамм, тогда вычтем из этой массы ту часть, что съест Машенька за 20 дней и получим массу оставшегося варенья через 20 дней:

650 - 500 = 150 грамм.

ответ: получили, что через 20 дней в банке останется всего 150 грамм варенья.

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Дружественные числа – это два натуральных числа, таких, что сумма всех делителей одного числа (меньших самого этого числа) равна другому числу, и наоборот. напишите программу, которая будет искать дружеские пары чисел до 100 000. pascal
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

Rjkjneirbyf555
titancore
officem695
nikolai37
ganorussia
srgymakarov
stolle16
necit12
ВасилийКлимова1695
akrivoz
Kuzina Sergeevna
dima0218687
egcuzn86
Mariya987
yakovlevasvetlanalvovna209