Информатика для меня как маленький лучик который даёт и свет и знания.
В Информатике я могу научиться пользоваться компьютером и может быть я в будущем стану програмистом. Щас великая роль информатики развития общества,веть если нет информации значит нет и разговора.Щас мир быстро меняется мы не знаем что может случится через два-три года вдруг мы успеем сделать машину времени или телевизор который может скручиваться как ковёр.Может быть то что мы придумаем не решит все наши проблемы,но решит что будем делать в дальнейшем будущем.
Информация это золото в недрах камнях,чтобы овладеть полностью информации нужно века чтоб докапать всё золото.
Информатика для меня как маленький лучик который даёт и свет и знания.
В Информатике я могу научиться пользоваться компьютером и может быть я в будущем стану програмистом. Щас великая роль информатики развития общества,веть если нет информации значит нет и разговора.Щас мир быстро меняется мы не знаем что может случится через два-три года вдруг мы успеем сделать машину времени или телевизор который может скручиваться как ковёр.Может быть то что мы придумаем не решит все наши проблемы,но решит что будем делать в дальнейшем будущем.
Информация это золото в недрах камнях,чтобы овладеть полностью информации нужно века чтоб докапать всё золото.
Поделитесь своими знаниями, ответьте на вопрос:
Составьте программу которая находит 50 случайных целых чисел на промежутке от -30 до 10 и находит среднее арифметическое всех положительных чисел промежутка
#include <iostream>
#include <ctime>
using namespace std;
int main()
{
double a[50], s = 0, count = 0;
srand(time(NULL));
for (int i = 0; i < 50; i++)
{
a[i] = -30 + rand() % 41;
if(a[i]>0)
{
s += a[i];
count++;
}
}
cout << s / count << endl;
system("pause");
return 0;
}
Выражение rand() % 41 рандомно принимает любое возможное значение остатка при делении на 41 ( от нуля до 40-а), следовательно -30+ rand()%41 рандомно принимает значение от -30-и до 10-и. Выбираем 50 таких рандомных чисел и храним их в массиве а, заодно в переменной s очередное число, если оно положительное а в переменной count считаем количество положительных чисел. s/count будет средней арифметической всех положительных чисел промежутка.