MArat
?>

Напишите программу, которая вводит натуральное число n , затем – n целых чисел, и вычисляет их сумму и произведение

Информатика

Ответы

dakimov

Программа на паскале, не знаю какой язык тебе нужен

Var

n,s,p,i:integer;

Begin

read(n);

s:=0;

p:=1;

For i:= 1 to n do begin

read(n);

s:=s+i;

p:=p*i;

end;

write('Сумма равна: ',s,', Произведение равно: ',p);

end.

ВладимировичМорозова1941
 Фильтры позволя­ют отбирать записи, которые удовлетворяют заданным усло­виям. Условия отбора записей создаются с использованием операторов сравнения (=, >, < и т. д.).Простой фильтр содержит условие отбора записей толь­ко для\ одного поля. Сложный фильтр содержит несколько условий для различных полей.

Запросы позволяют отобрать те записи, которые удовле­творяют заданным условиям. Запросы, как и фильтры, бы­вают простые и сложные. Простой запрос содержит одно ус­ловие, а сложный запрос содержит несколько условий для различных полей.
NIKOLAEVNA
#include <iostream>
#include <string>

typedef std::string STR;

STR ReactToMark();

int main() {
    STR mark = ReactToMark();
    std::cout << mark << '\n';
    return 0;
}

STR ReactToMark() {
    int mark;
    std::cout << "Оценка: ";
    std::cin >> mark;
    switch (mark) {
    case 1:
        return "Очень плохо, надо мне прийти в школу";
    case 2:
        return "Плохо, я тобой недовольна";
    case 3:
        return "Мог бы и лучше";
    case 4:
        return "Хорошо, но пятёрка лучше";
    case 5:
        return "Молодец, на выходных пойдёшь в кино";
    default:
        std::cout << " введи правильную оценку!" << '\n';
        return ReactToMark();
    }
}

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Напишите программу, которая вводит натуральное число n , затем – n целых чисел, и вычисляет их сумму и произведение
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

astahova
МихайловнаLarisa1150
aivia29
kamalfayed229
julya847
Шиловский126
NikolaevichIP1136
sergeymartyn56
lakeeva90
Viktorovna
mrilyushchenko6
Simbireva
yanva
kruttorg
edelstar83