Khlistova1488
?>

Напишите программу для яркостью “люстры” из трёх светодиодов, которая использует возможности работы с переменными, а также условную конструкцию if( ){ }else{ }. ваша программа должна по нажатию кнопки сначала включать один светодиод, по второму нажатию кнопки - два светодиода, по третьему нажатию - три светодиода, и выключать все три при следующем нажатии ардуино код

Информатика

Ответы

picsell

на 2 pin подключаем кнопку

на 3, 4, 5 pin подключаем светодиоды


а вот скетч


#include <Arduino.h>

#include <Wire.h>

#include <SoftwareSerial.h>

double angle_rad = PI/180.0;

double angle_deg = 180.0/PI;

double x;

void setup(){

   pinMode(2,INPUT);

   pinMode(3,OUTPUT);

   pinMode(4,OUTPUT);

   pinMode(5,OUTPUT);

}

void loop(){

   if(!((x) > (3))){

       if(((digitalRead(2))==(true))){

           x += 1;

           while(!(((digitalRead(2))==(false

           {

               _loop();

           }

       }

   }else{

       x = 0;

   }

   if((x) > (0)){

       digitalWrite(3,1);

   }else{

       digitalWrite(3,0);

   }

   if((x) > (1)){

       digitalWrite(4,1);

   }else{

       digitalWrite(4,0);

   }

   if((x) > (1)){

       digitalWrite(5,1);

   }else{

       digitalWrite(5,0);

   }

   _loop();

}

void _delay(float seconds){

   long endTime = millis() + seconds * 1000;

   while(millis() < endTime)_loop();

}

void _loop(){

}

Petrovich

uses crt;
type TRec = Record
FIO: String[20];
TEL: String[7]
end;
var rec: TRec; i:integer;
who:string; flag:boolean;
a: array [1..20] of TRec;

begin
a[1].FIO := 'Иванов Петр';
a[1].TEL := '+374844';
a[2].FIO := 'Крылова Света';
a[2].TEL := '+373129';
a[3].FIO := 'Соловей Иван';
a[3].TEL := '+370929';
//создай дальше до 10 сама
write('Write fio '); readln(who);
for i:=1 to 3 do
begin

if a[i].FIO = who then
begin
writeln('Номер ',who,' = ',a[i].TEL) ;
flag:=true;
end
else
flag:=false;
end;
if flag=false then
writeln('cannot find ',who);
readln;
end.

Alekseevna

Я так понимаю, что вы хотели в программе проверить числа на четность/нечетность, но программа по вашему коду этого не сделает.

 

В таком виде должно быть без ошибок, но работает по-прежнему неверно:

 

#include "stdio.h"
//#include "math.h"
#include <iostream>
using namespace std;

int main ( )
{
float *a;
int i,n;
printf("n=");
scanf("%i",&n);
a=(float*)malloc(n*sizeof(float));
for( i=0; i<=n-1;i++ )
{
printf("a[%i]= ",i );
scanf("%i",&a[i]);
}
for (i=0; i<=n-1; i++)
{
if (a[i]<0)
{
printf("oshibka\n");
}
else
{
if (a[i]/2==0)
{
printf("chetnoe \n");
}
else
{
printf("nechetnoe\n");
}
}

}
system("pause");
return 1;
}

 

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Напишите программу для яркостью “люстры” из трёх светодиодов, которая использует возможности работы с переменными, а также условную конструкцию if( ){ }else{ }. ваша программа должна по нажатию кнопки сначала включать один светодиод, по второму нажатию кнопки - два светодиода, по третьему нажатию - три светодиода, и выключать все три при следующем нажатии ардуино код
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

Gainalii1912
Veronika1270
Levinalx4938
shneider1969
Павловна1750
waspmoto6188
zotcet7
lavr74
IAleksandrovna45
sharaeva-is
rykovatv6
dvpered
Darialaza
oalexandrova75
olimov