alukyanov
?>

Нужно написать программу которая при вводе координат начальной и конечной ячеек шахматной доски будет решать возможен ли ход в конечную ячейку шахматной фигуры «слон». программа должна вывести: «yes» если ход возможен и «no» если нет. решение в c++

Информатика

Ответы

nkaminskaja

#include <iostream>

using namespace std;

int main(){

long long x1,x2,y,y2;

 cout<<"Enter x1:";

 cin>>x1; // вводим начальную координату по горизонтали

 cout<<"Enter y1:";

 cin>>y; // вводим начальную координату по вертикали

 cout<<"Enter x2:";

 cin>>x2; // вводим конечную координату по горизонтали

 cout<<"Enter y2:";

 cin>>y2; // вводим координату координату по вертикали

if(x1 - y == x2 - y2 || x1 + y == x2 + y2){

 cout << "YES";

}

else{

 cout << "NO";

}

}


else{

 cout << "NO";

}

}

Tarapovskaya

#include "stdafx.h"  

#include <iostream>  


using namespace std;  


int main()  

{  

// input data  

int x1, y1, x2, y2;  


// get data  

co

aifbon

уточнять на каком языке программирования нужно написать задачки. Я же напишу на С++. Алгоритм везде будет один и тот же.

1 задача

int x1 = 0;

int x2 = 0;

int x3 = 0;

int x4 = 0;

int x5 = 0;

cin >> x1;

cin >> x2;

cin >> x3;

cin >> x4;

cin >> x5;

double sr = 0.0;

sr = (x1+x2+x3+x4+x5)/5;

Или же можно сделать по проще

int x = 0;

int sum = 0;

double sr = 0.0;

for(int i = 0; i<5; i++){

cin >> x;

sum = sum +x;

}

sr = sum/5;

2 Задача

int number = 5;

for(int i = 2; i<20; i=i+2){

number = number + i;

}

Александр Сергей

уточнять на каком языке программирования нужно написать задачки. Я же напишу на С++. Алгоритм везде будет один и тот же.

1 задача

int x1 = 0;

int x2 = 0;

int x3 = 0;

int x4 = 0;

int x5 = 0;

cin >> x1;

cin >> x2;

cin >> x3;

cin >> x4;

cin >> x5;

double sr = 0.0;

sr = (x1+x2+x3+x4+x5)/5;

Или же можно сделать по проще

int x = 0;

int sum = 0;

double sr = 0.0;

for(int i = 0; i<5; i++){

cin >> x;

sum = sum +x;

}

sr = sum/5;

2 Задача

int number = 5;

for(int i = 2; i<20; i=i+2){

number = number + i;

}

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Нужно написать программу которая при вводе координат начальной и конечной ячеек шахматной доски будет решать возможен ли ход в конечную ячейку шахматной фигуры «слон». программа должна вывести: «yes» если ход возможен и «no» если нет. решение в c++
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

asemchenko
Ladiga_Evgenii886
valya-7777
svetavancevich
Владимирович111
verav75
dkedrin74038
Pona4ka93
maestro6838
Nikita_Lina1305
damir
uglichdeti
zakupki
ikuvila5484
turoverova5