C++ дан массив, состоящий из целых чисел. известно, что числа по неубыванию (то есть каждый следующий элемент не меньше предыдущего напишите программу, которая определит количество различных чисел в этом массиве.
// ConsoleApplication13.cpp: определяет точку входа для консольного приложения.
//
#include "stdafx.h"
#include <iostream>
using namespace std;
int main()
{
int a;
int b, c, col;
int d[100];
for (b = 1; b <= 100; b++) {
d[b] = 0;
}
cin >> a;
bool f;
col = 0;
for (b = 1; b <= a; b++) {
f = true;
cin >> d[b];
for (c = 1; c < b; c++) {
if (d[b] == d[c]) {
f = false;
}
}i
f (f){ col++; }
}
cout << col;
return 0;
}
ПетровичЖивотовская1245
23.07.2021
Если по минимальным требованиям компьютер подходит то попробуй отключить вертикальную синхронизацию в настройках видеокарты .
Если ваша видеокарта относится к семейству Geforce, нажмите правой кнопкой на рабочем столе и выберите пункт меню «Панель управления nVidia». Другой вариант — откройте панель управления через меню «Пуск», там будет иконка запуска с тем же названием. Если ни в панели управления, ни в меню рабочего стола вы не нашли нужную иконку, посмотрите возле часов в правом углу экрана, там будет зеленый значок nVidia, похожий на глаз — дважды щелкните на нем. По итогу откроется меню настроек видеокарты. Окно панели управления драйвера состоит из двух частей, в левой части находятся категории действий, а в правой — возможные варианты и информация. Выберите в левой части нижнюю строчку «Управление параметрами 3D». В правой части окна, на закладке «Глобальные параметры», найдите в самом верху списка опцию «Вертикальный синхроимпульс». Напротив будет указана текущая настройка: «Включить», «Отключить» или «Настройки приложения». Выберите из выпадающего списка вариант «Отключить» и подтвердите свой выбор, нажав кнопку «Применить».
Также посмотри в диспетчере задач запущенные процессы,отключи лишнее или то что много жрёт памяти . Возможно у тебя вирус,проверь антивирусом,например AVG . Также рекомендую прочистить компьютер ,тогда возможно будет лучше (CCleaner) .Если ничего не то поставь настройки графики пониже.
anastasiavilina
23.07.2021
Тут довольно простое задание, которое можно решить просто подбором (найти правильное основание системы, и заодно выяснить что за цифры соответствуют остальным символам).Я объясню немного подробнее логику рассуждений при таком решении. Итак:символ # это 1запись # * это 4запись # @ это 7 Найти, чему равна запись @ * # Для того, чтобы это найти, нам надо узнать основание используемой здесь системы счисления. Обозначим его как x.Вспомним, что основание системы счисления- это целое число не меньше двух (x ≥ 2). Рассмотрим запись числа четыре: (это перевод числа из системы с основанием x в десятичную)Раз запись числа 4 состоит из двух разрядов, значит основание системы не может быть больше четырёх (x≤4).Ведь уже при основании пять (x = 5) вес второго разряда числа был бы равен пяти (), и всё число было бы явно больше четырёх. Далее, рассмотрим запись числа семь: Мы видим, что второй разряд не изменился- здесь тоже стоит единица. А само число увеличилось на три (7 - 4 = 3). Значит, на три увеличилась цифра в первом разряде (была *, стала @). То есть, Итак, основание- это целое число, не меньше двух и не больше четырёх. Подходят всего три числа- 2, 3, 4.В каком из этих оснований системы можно прибавить к цифре три без переноса в следующий разряд?если основание 2 -то есть всего две цифры: 0 и 1если основание 3 -то есть три цифры: 0, 1 и 2если основание 4 -то четыре цифры: 0, 1, 2 и 3Такие цифры используются в одном разряде. И, если при сложении мы выходим за эти цифры, то произойдёт перенос в следующий разряд (чего у нас не было, во втором разряде осталась единица). Получается, что в пределах одного разряда, тройку можно прибавить только в системе с основанием 4, причём только в одном случае (0 + 3 = 3).Значит:символ * это 0символ @ это 3а основание системы счисления равно четырём Осталось перевести запись @ * # из четверичной в десятичную систему счисления:
// ConsoleApplication13.cpp: определяет точку входа для консольного приложения.
//
#include "stdafx.h"
#include <iostream>
using namespace std;
int main()
{
int a;
int b, c, col;
int d[100];
for (b = 1; b <= 100; b++) {
d[b] = 0;
}
cin >> a;
bool f;
col = 0;
for (b = 1; b <= a; b++) {
f = true;
cin >> d[b];
for (c = 1; c < b; c++) {
if (d[b] == d[c]) {
f = false;
}
}i
f (f){ col++; }
}
cout << col;
return 0;
}