Дементьева-Артем1315
?>

Необходимо решить следующую предметную и написать программу на языке паскаль. для любого целого k обозначим количество цифр в его десятичной записи ц(k например: ц(1)=1, ц(9)=1, ц(10)=2. дано натуральное число n. вычислить: ( ц(1)/1 ) + ( ц(2)/2^2 ) + +( ц(n)/n^2 )

Информатика

Ответы

Mikhailovna_Litvinova276

program crash;

 

var n, k: integer;

   r: real;

 

begin

 write('n = ');

 readln(n);

 k := 0;

 r := 0;

 while n > 0 do

   begin

     k := k + 1;

     r := r + (n mod 10) / (k * k);

     n := n div 10

   end;

 writeln('r = ', r:0:14);

 readln

end.

Novikova Aleksandrovna
#include <iostream>
#include <list>

using namespace std;

int main() {
    list<int>mylist;
    //Делаем со списком, что хотим
    mylist.push_back(1);
    mylist.push_back(2);
    mylist.push_back(3);
    mylist.push_back(-4);
    mylist.push_back(5);
    for (auto i : mylist) {
        cout << i << " ";
    }
    cout << "\n";
    //Удаляем последний отрицательный элемент
    auto it = mylist.end();
    while (*it > 0) {
        if (it == mylist.begin()) {
            cout << "Not found.\n";
            return 0;
        }
        it--;
    }
    //Делаем со списком, что хотим
    mylist.erase(it);
    for (auto i : mylist){
        cout << i << " ";
    }
    return 0;
}
inris088

Графический интерфейс (Graphical User Interface или GUI) создан для более удобного взаимодействия с пользователем (в отличии от просто командно-текстового взаимодействия или консоли)

Надпись, иконка - элементы для вывода информации текстовой и графической соответственноКнопка - базовый функциональный элемент для запуска определенной команды. Может содержать иконки и надписиТекстовое поле - одно/много-строчное, для вывода и ввода текстовой информации. Пункт меню - вариация кнопкиМеню - обычно древовидное объединение нескольких пунктов менюОбласти для вывода изображений и видеоКурсор мыши - элемент для удобного взаимодействия со всем вышеперечисленным

Не совсем точно, но более менее понятно. Так или иначе из комбинации этих элементов и состоят все графические интерфейсы

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Необходимо решить следующую предметную и написать программу на языке паскаль. для любого целого k обозначим количество цифр в его десятичной записи ц(k например: ц(1)=1, ц(9)=1, ц(10)=2. дано натуральное число n. вычислить: ( ц(1)/1 ) + ( ц(2)/2^2 ) + +( ц(n)/n^2 )
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

ckiras9
potemkin77
Georgievich-Zamudinovna2003
Mnatsovna
sindika
Абдулганиева Сергей
oliayur4encko
nadejdashin508
НосовЖелиховская
Serezhkin
tanyashevvvv
ludmila-malev280
stmr29
thedoomsdatdcs36
miha23727
▲