hr2251
?>

Составьте программу , которая формирует массив из 10 целых чисел значения которых лежат в интервале от - 10 до 10 ( [ 10: 10] ) . программа должна выводить на экран исходный массив затем преобразовать элементы массива , увеличивая в два раза положительные элементы , а для отрицательных элементы менять знак на противоположный . выведите на экран преобразованный массив . в паскале !

Информатика

Ответы

dashasnegirva

const n=10;

var a:array[1..n] of integer;

i: integer;

begin

for i:=1 to n do

begin

a[i]:=random(21)-10;

write (a[i]:3,' ');

if a[i]>0 then a[i]:=a[i]*2;

if a[i]<0 then a[i]:=-a[i]

end;

writeln;

for i:=1 to n do write (a[i]:3,' ')

end.

elenaneretina
Я так понимаю, что рассматривается ситуация, когда текстовая информация имеется, а ее надо как-то проанализировать.
Недостатки
 - сложно ставить пометки, мы привыкли делать пометки руками, и в электронном виде это все равно несколько неудобно.
 - самый большой недостаток, это то что нельзя выложить несколько листов и смотреть на них одновременно. Упираемся в размеры монитора и тд.
- усталость глаз от долговременной работы с монитором

Опять таки ко всему можно при если часто приходится делать, но для одноразового случая лучше распечатать информацию
yna21289
#include <iostream>
#include <cmath>

class point
{
    int x;
    int y;
public:
    point(): x(0), y(0) {}
    void setkoord(int koordx,int koordy)
    {
        x = koordx;
        y = koordy;
    }
    int getx()const { return x; }
    int gety()const { return y; }
};

double length(point p1, point p2)
{
     return (sqrt(pow(double(p1.getx()-p2.getx()),2)+pow(double(p1.gety()-p2.gety()),2)));
}

int main()
{
    point A,B,C;
    B.setkoord(1,1);
    C.setkoord(1,0);
    double a=length(A,B), b=length(B,C), c=length(C,A);
    double p=(a+b+c)/2;
    double s=sqrt(p*(p-a)*(p-b)*(p-c));
    std::cout <<"square: " <<s <<std::endl;
    return 0;
}

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Составьте программу , которая формирует массив из 10 целых чисел значения которых лежат в интервале от - 10 до 10 ( [ 10: 10] ) . программа должна выводить на экран исходный массив затем преобразовать элементы массива , увеличивая в два раза положительные элементы , а для отрицательных элементы менять знак на противоположный . выведите на экран преобразованный массив . в паскале !
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

Nataliefremova2015808
Нескажу25
anna-ditman
rmitin
tooltechnic
italiankarest
AleksandrIvanovich1273
makscska22879
dkedrin74038
КалюкМарасанов1026
Sacharov84
paninsv
tvtanya80
cmenick29
ev89036973460