Zhanibekrva Kandaurova
?>

Составьте программу, реализующую эпизод применения компьютера в книжном магазине. компьютер запрашивает стоимость книг и сумму денег, внесенную покупателем. если сдачи не требуется, печатает на экране «». еслиденег внесено больше, то печатает «возьмите сдачу» и указывает сумму сдачи. если денег недостаточно, то печатает об этом сообщение и указывает размер недостающей суммы.

Информатика

Ответы

Batrakova-Anna

qbasic

 

? "введите стоимость книг и сумму денег соответсвенно через запятую"

input a,b

if a=b then 1 else 2

1 ? "" : goto 10

2 if a> b then 3 else 4

3 a-b=c

? "не хватает денег,доплатите"; c : goto 10

4 b-a=r

? "ваша здача"; r

10 end

Nivanova995
  №1. #include< iostream> #include< math.h> using namespace std; long i,sum; int main() { for(i=10; i< =30; i++) { sum+=i; cout< < sum< < endl; } return 0;   } #include< iostream> #include< math.h> using namespace std; long i,sum; int main() {   i=10; sum=0; while(i< =30) { sum+=i; cout< < sum< < endl; i++; }   return 0; } #include< iostream> #include< math.h> using namespace std; long i,sum; int main() {   i=10; sum=0; do { sum+=i; cout< < sum< < endl; i++; } while(i< =30); return 0; } №2 #include< iostream> #include< math.h> using namespace std; long i,a,b,k; int main() {   cin> > a; for(i=1; i< =10; i++) { cin> > b; if(b==a) k++; } cout< < k;   return 0; } #include< iostream> #include< math.h> using namespace std; long i,a,b,k; int main() { i=1; cin> > a; while(i< =10) { cin> > b; if(b==a) k++; i++; } cout< < k; return 0; } #include< iostream> #include< math.h> using namespace std; long i,a,b,k; int main() { i=1; cin> > a; do { cin> > b; if(b==a) k++; i++; } while(i< =10); cout< < k; return 0; } №3 #include< iostream> #include< math.h> using namespace std; long a,b,k; int main() { cin> > a> > b; k=a*a+abs(b)+5*a-10*b; cout< < k; return 0; } №4 #include< iostream> #include< math.h> using namespace std; long a,b,k; int main() { cin> > a; if(a> =0) a++; else a-=2; return 0; } №5 #include< iostream> #include< math.h> using namespace std; double i,u; int main() { for(i=0; i< =10; i+=0.3) { u=i+1; cout< < u< < endl; } return 0; }
vladimirdoguzov
Program zadacha; type mas=array[0..100] of integer;   //так делается тип твоего массива var m: mas;     // обозначается       i,n: integer; begin          readln(n);     // вводится длина массиа         for i: =1 to n do begin // начинаем цикл             m[i]: =i;     // присваивает элементу массива как значение -  его номер             write(m[i],' ');   // печатаем         end;     // заканчиваем цикл         readln; // вводится, чтобы консоль сразу не закрывалась(будешь сдавать в         систему - не end.

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Составьте программу, реализующую эпизод применения компьютера в книжном магазине. компьютер запрашивает стоимость книг и сумму денег, внесенную покупателем. если сдачи не требуется, печатает на экране «». еслиденег внесено больше, то печатает «возьмите сдачу» и указывает сумму сдачи. если денег недостаточно, то печатает об этом сообщение и указывает размер недостающей суммы.
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

manuchar-formen2
Тимур
svetegal
vitaliy
laplena1982750
Umkatoys50
boldyrevanastia22
Татьяна_Вологжин
stmr29
aa276568
МихайловнаLarisa1150
Pervosha
Avetisyan575
Роман1406